aboutsummaryrefslogtreecommitdiffstats
path: root/main/heimdal/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-12-15 13:35:32 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-12-15 13:35:48 +0000
commit612a6e7c6479acd09214b6d99c95cbdb26d40b90 (patch)
tree75e1d48452a86247b53af3368552de109d17f4c9 /main/heimdal/APKBUILD
parent07f10cea7c5ec14e9ddc18575d4a2f2aeea74f0a (diff)
main/heimdal: upgrade to 1.4
Diffstat (limited to 'main/heimdal/APKBUILD')
-rw-r--r--main/heimdal/APKBUILD44
1 files changed, 19 insertions, 25 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index 36bae5db89c..2f7efb84b24 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -1,11 +1,10 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
-pkgver=1.3.3
+pkgver=1.4
pkgrel=0
pkgdesc="An implementation of Kerberos 5"
url="http://www.h5l.org/"
-arch="x86 x86_64"
license="BSD"
depends=
makedepends="gawk readline-dev e2fsprogs-dev>=1.41.9-r2 sqlite-dev autoconf automake
@@ -18,45 +17,42 @@ source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
002_all_heimdal-fPIC.patch
003_all_heimdal-rxapps.patch
005_all_heimdal-suid_fix.patch
-013_all_heimdal-pthread-lib.patch
014_all_heimdal-path.patch
-100-check-com_err-pthread.patch
-heimdal-locate_plugin-header.patch
+heimdal-1.4-make.patch
"
-
# krb5.h needs com_err.h
depends_dev="e2fsprogs-dev"
+_builddir="$srcdir/$pkgname-$pkgver"
+
prepare() {
[ -e /usr/lib/libasn1.so ] && echo "## remove old heimdal pkg first ##" && return 1
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
- patch -Np0 -i ../001_all_heimdal-no_libedit.patch || return 1
- patch -Np0 -i ../002_all_heimdal-fPIC.patch || return 1
- patch -Np0 -i ../003_all_heimdal-rxapps.patch || return 1
- patch -Np0 -i ../005_all_heimdal-suid_fix.patch || return 1
- patch -Np1 -i ../013_all_heimdal-pthread-lib.patch || return 1
- patch -Np0 -i ../014_all_heimdal-path.patch || return 1
- patch -Np1 -i ../100-check-com_err-pthread.patch || return 1
- patch -Np1 -i ../heimdal-locate_plugin-header.patch || return 1
+ for i in ../*.patch
+ do
+ msg "Applying patch $i"
+ patch -p0 -i $i || return 1
+ done
# name clash with ruserpass in netdb.h
sed -i -e 's/ruserpass/ruserpw/g' appl/ftp/ftp/*.[ch] || return 1
- sed -i -e 's|var/heimdal|var/lib/heimdal|g' configure.in \
- doc/setup.texi doc/heimdal.info kadmin/kadmind.8 kdc/kdc.8 \
- lib/hdb/hdb.h lib/krb5/krb5.conf.5 lib/krb5/krb5.conf.cat5
+# sed -i -e 's|var/heimdal|var/lib/heimdal|g' configure.in \
+# doc/setup.texi doc/heimdal.info kadmin/kadmind.8 kdc/kdc.8 \
+# lib/hdb/hdb.h lib/krb5/krb5.conf.5 lib/krb5/krb5.conf.cat5 || return 1
sh ./autogen.sh || return 1
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
export LDFLAGS="${LDFLAGS} -Wl,--as-needed"
./configure --prefix=/usr \
- --enable-shared=yes --without-x \
+ --enable-shared=yes \
+ --without-x \
--disable-berkeley-db \
--with-readline-lib=/usr/lib \
--with-readline-include=/usr/include/readline \
@@ -66,7 +62,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" exec_prefix=/usr sysconfdir=/etc \
mandir=/usr/share/man infodir=/usr/share/info datadir=/var/lib/heimdal \
localstatedir=/var/lib/heimdal libexecdir=/usr/sbin install
@@ -166,12 +162,10 @@ kf() {
mv $pkgdir/usr/bin/kf $subpkgdir/usr/bin/kf
}
-md5sums="963c09f1b14c41660be70b55fae9f163 heimdal-1.3.3.tar.gz
+md5sums="31d08bbf47a77827fe97ef3f52b4c9c4 heimdal-1.4.tar.gz
98e28f11f906c967aac22d6184102c9e 001_all_heimdal-no_libedit.patch
6d5571bdedba2e2423b90bccdbac2c0a 002_all_heimdal-fPIC.patch
2feec3924ee5230b54175b4d4000c872 003_all_heimdal-rxapps.patch
45aeb207f360f9f4e9e0fabc8bfeecbc 005_all_heimdal-suid_fix.patch
-1b8665b771c4eb6b56ea8582c96e56e3 013_all_heimdal-pthread-lib.patch
8208ae8c0b6ff5ab4f64af1693e9e396 014_all_heimdal-path.patch
-e73205200f9641b5d969427ffb04282a 100-check-com_err-pthread.patch
-248ab80b44568171e432a23524f4fe39 heimdal-locate_plugin-header.patch"
+fa1753ec676029cd59a3ef24da55c144 heimdal-1.4-make.patch"