summaryrefslogtreecommitdiffstats
path: root/main/heimdal
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-06-19 09:02:05 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-06-19 09:02:05 +0000
commit85fd77589be2f6c970ca6895afa1520e0a2fda04 (patch)
tree6b9d172b005b2657e541424da71009dcd2a1f3c4 /main/heimdal
parent8fdcdf953f865c691b01d546a0baea1a1143deeb (diff)
parent253afa4a86bcb0959ca8b7fb269f482058847a9b (diff)
Merge remote branch 'alpine/master'
Conflicts: main/openssl/APKBUILD
Diffstat (limited to 'main/heimdal')
-rw-r--r--main/heimdal/APKBUILD14
-rw-r--r--main/heimdal/heimdal-c++-safe-krb5_cccol_cursor.patch26
2 files changed, 4 insertions, 36 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index deab8f86871..1bf4d91fc12 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
-pkgver=1.3.1
-pkgrel=5
+pkgver=1.3.3
+pkgrel=0
pkgdesc="An implementation of Kerberos 5"
url="http://www.h5l.org/"
license="BSD"
@@ -20,9 +20,7 @@ source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
013_all_heimdal-pthread-lib.patch
014_all_heimdal-path.patch
100-check-com_err-pthread.patch
-heimdal-c++-safe-krb5_cccol_cursor.patch
heimdal-locate_plugin-header.patch
-return-invalid-enctype-for-weak-crypto.patch
"
# krb5.h needs com_err.h
@@ -40,9 +38,7 @@ prepare() {
patch -Np1 -i ../013_all_heimdal-pthread-lib.patch || return 1
patch -Np0 -i ../014_all_heimdal-path.patch || return 1
patch -Np1 -i ../100-check-com_err-pthread.patch || return 1
- patch -Np1 -i ../heimdal-c++-safe-krb5_cccol_cursor.patch || return 1
patch -Np1 -i ../heimdal-locate_plugin-header.patch || return 1
- patch -Np1 -i ../return-invalid-enctype-for-weak-crypto.patch || return 1
# name clash with ruserpass in netdb.h
sed -i -e 's/ruserpass/ruserpw/g' appl/ftp/ftp/*.[ch] || return 1
@@ -169,7 +165,7 @@ kf() {
mv $pkgdir/usr/bin/kf $subpkgdir/usr/bin/kf
}
-md5sums="4ce17deae040a3519e542f48fd901f21 heimdal-1.3.1.tar.gz
+md5sums="963c09f1b14c41660be70b55fae9f163 heimdal-1.3.3.tar.gz
98e28f11f906c967aac22d6184102c9e 001_all_heimdal-no_libedit.patch
6d5571bdedba2e2423b90bccdbac2c0a 002_all_heimdal-fPIC.patch
2feec3924ee5230b54175b4d4000c872 003_all_heimdal-rxapps.patch
@@ -177,6 +173,4 @@ md5sums="4ce17deae040a3519e542f48fd901f21 heimdal-1.3.1.tar.gz
1b8665b771c4eb6b56ea8582c96e56e3 013_all_heimdal-pthread-lib.patch
8208ae8c0b6ff5ab4f64af1693e9e396 014_all_heimdal-path.patch
e73205200f9641b5d969427ffb04282a 100-check-com_err-pthread.patch
-7ebff9a320f18ed62f5fcb68c8fc18b8 heimdal-c++-safe-krb5_cccol_cursor.patch
-248ab80b44568171e432a23524f4fe39 heimdal-locate_plugin-header.patch
-a8342f77a1aedb4f332983bcbf141827 return-invalid-enctype-for-weak-crypto.patch"
+248ab80b44568171e432a23524f4fe39 heimdal-locate_plugin-header.patch"
diff --git a/main/heimdal/heimdal-c++-safe-krb5_cccol_cursor.patch b/main/heimdal/heimdal-c++-safe-krb5_cccol_cursor.patch
deleted file mode 100644
index c688794533b..00000000000
--- a/main/heimdal/heimdal-c++-safe-krb5_cccol_cursor.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- heimdal-1.3.1-old/lib/krb5/cache.c Sat Nov 21 15:41:51 2009
-+++ heimdal-1.3.1/lib/krb5/cache.c Thu Jan 21 09:12:13 2010
-@@ -1347,10 +1347,11 @@
- *
- */
-
--struct krb5_cccol_cursor {
-+struct krb5_cccol_cursor_data {
- int idx;
- krb5_cc_cache_cursor cursor;
- };
-+/* typedef of krb5_cccol_cursor is in krb5.h */
-
- /**
- * Get a new cache interation cursor that will interate over all
---- heimdal-1.3.1-old/lib/krb5/krb5.h Sat Nov 21 15:41:51 2009
-+++ heimdal-1.3.1/lib/krb5/krb5.h Thu Jan 21 09:12:54 2010
-@@ -311,7 +311,7 @@
- NULL)
-
- typedef void *krb5_cc_cursor;
--typedef struct krb5_cccol_cursor *krb5_cccol_cursor;
-+typedef struct krb5_cccol_cursor_data *krb5_cccol_cursor;
-
- typedef struct krb5_ccache_data {
- const struct krb5_cc_ops *ops;