aboutsummaryrefslogtreecommitdiffstats
path: root/main/hunspell/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-26 12:17:58 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-27 12:22:20 +0000
commit69775f62b9505467a3311fdfc2f7552786d20697 (patch)
tree66e47f6ece8bc47e5676d9b35e8240065d1047ce /main/hunspell/APKBUILD
parent5164608aabae7bd063a7a58573e2e297c8a66584 (diff)
main/hunspell: upgrade to 1.6.0
Diffstat (limited to 'main/hunspell/APKBUILD')
-rw-r--r--main/hunspell/APKBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index 9de161712c1..982b64e387e 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hunspell
-pkgver=1.4.1
+pkgver=1.6.0
pkgrel=0
pkgdesc="Spell checker and morphological analyzer library and program"
url="http://hunspell.github.io/"
@@ -8,22 +8,19 @@ arch="all"
license="GPL2+ LGPL2+ MPL 1.1"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
depends=""
-makedepends="gettext-dev ncurses-dev readline-dev"
+makedepends="gettext-dev ncurses-dev readline-dev autoconf automake libtool"
source="$pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v$pkgver.tar.gz
"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ default_prepare || return 1
+ autoreconf -vif || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -37,10 +34,10 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="33d370f7fe5a030985e445a5672b2067 hunspell-1.4.1.tar.gz"
-sha256sums="c4476aff0ced52eec334eae1e8d3fdaaebdd90f5ecd0b57cf2a92a6fd220d1bb hunspell-1.4.1.tar.gz"
-sha512sums="6edc1120a08d46f1c3a590f9964486240eee46ef7f1c2d072c228d26dd1cb3bee1f283d007fcda994cdf0482c065cd5375c9706570a7c5be9aff423e19c03b6b hunspell-1.4.1.tar.gz"
+md5sums="047c3feb121261b76dc16cdb62f54483 hunspell-1.6.0.tar.gz"
+sha256sums="512e7d2ee69dad0b35ca011076405e56e0f10963a02d4859dbcc4faf53ca68e2 hunspell-1.6.0.tar.gz"
+sha512sums="d13e0384654f98f87de61d3d6ec03fe4a0e972b49b7e220083c72c2dd99d169a4854160f7068baa34fe4d4bd85fa5c24b56587827b946fb072a2085173801ca9 hunspell-1.6.0.tar.gz"