aboutsummaryrefslogtreecommitdiffstats
path: root/main/icu
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-09 02:56:49 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:41 +0000
commite6891e2d085c033766245ff853783659ebef560d (patch)
tree9b62d5843a6ffec94cd9bed471ec588fad2e90ab /main/icu
parentebbefcbaaa641753c6c226081e93c12f584d74aa (diff)
main/icu: modernise and add test suite
Diffstat (limited to 'main/icu')
-rw-r--r--main/icu/APKBUILD29
1 files changed, 12 insertions, 17 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index f862e507313..246f7c17cbc 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -6,7 +6,7 @@ pkgver=59.1
# convert x.y.z to x_y_z
_ver=${pkgver//./_}
-pkgrel=0
+pkgrel=1
pkgdesc="International Components for Unicode library"
url="http://www.icu-project.org/"
arch="all"
@@ -30,7 +30,8 @@ builddir="$srcdir"/icu/source
prepare() {
cd "$builddir"
- update_config_sub || return 1
+ default_prepare
+ update_config_sub
# strtod_l() is not supported by musl; also xlocale.h is missing
# It is not possible to disable its use via configure switches or env vars
@@ -42,17 +43,7 @@ prepare() {
local x
# https://bugs.icu-project.org/trac/ticket/6102
for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" \
- || return 1
- done
-
- for i in $source; do
- case "$i" in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
+ sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in"
done
}
@@ -65,14 +56,18 @@ build() {
--sysconfdir=/etc \
--with-data-packaging=library \
--disable-samples \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
chmod +x "$pkgdir"/usr/bin/icu-config
install -Dm644 "$srcdir"/icu/license.html \
"$pkgdir"/usr/share/licenses/icu/license.html