aboutsummaryrefslogtreecommitdiffstats
path: root/main/imagemagick/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-30 08:14:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-30 08:15:25 +0000
commit526a480188b8e698edc4b0567f755aa63ccb58c8 (patch)
treeb97e4d0b9af0348d21d1e1921299171031ad05a1 /main/imagemagick/APKBUILD
parentef03517cdc2d4ffe4a1ab2051baa62fcba6810b0 (diff)
main/imagemagick: build with x11 support
we pull in x11 libraries anyways due to librsvg and pango so it does not make any sense to not build the reset with libx11.
Diffstat (limited to 'main/imagemagick/APKBUILD')
-rw-r--r--main/imagemagick/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index 0c12b753dcf..a72fd9aebdd 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -5,7 +5,7 @@ pkgname=imagemagick
pkgver=7.0.7.28
_abiver=7
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=0
+pkgrel=1
pkgdesc="Collection of tools and libraries for many image formats"
url="http://www.imagemagick.org"
arch="all"
@@ -13,7 +13,7 @@ license="ImageMagick"
options="libtool !checkroot"
makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev fontconfig-dev
perl-dev ghostscript-dev libwebp-dev libtool tiff-dev lcms2-dev
- libwebp-dev libxml2-dev librsvg-dev"
+ libwebp-dev libxml2-dev librsvg-dev libx11-dev libxext-dev"
checkdepends="freetype fontconfig ghostscript ghostscript-fonts lcms2 graphviz"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs"
source="http://www.imagemagick.org/download/releases/ImageMagick-$_pkgver.tar.xz"
@@ -40,7 +40,7 @@ build() {
--disable-static \
$_openmp \
--with-threads \
- --without-x \
+ --with-x \
--with-tiff \
--with-png \
--with-webp \