aboutsummaryrefslogtreecommitdiffstats
path: root/main/imlib2
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-07-15 08:36:50 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-07-15 08:56:21 +0000
commit64404d37152700c946764ea0eb6f352612d57c13 (patch)
tree685398ded1408d995b78f6d0bcac4675c0aa01ae /main/imlib2
parent9feb913b7e1beed4fd57761f75c623a3c9f2330e (diff)
main/imlib2: rebuild against giflib 5.1
Diffstat (limited to 'main/imlib2')
-rw-r--r--main/imlib2/APKBUILD8
-rw-r--r--main/imlib2/imlib2-giflib5.patch64
2 files changed, 61 insertions, 11 deletions
diff --git a/main/imlib2/APKBUILD b/main/imlib2/APKBUILD
index 9bd61b2b626..0e10d0bae7f 100644
--- a/main/imlib2/APKBUILD
+++ b/main/imlib2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imlib2
pkgver=1.4.6
-pkgrel=2
+pkgrel=3
pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
url="http://sourceforge.net/projects/enlightenment/"
arch="all"
@@ -48,11 +48,11 @@ package() {
install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
md5sums="5c7104121ec6db652b37f74a6d7048e2 imlib2-1.4.6.tar.bz2
-afc474880648ab32d26bae7b04e40abb imlib2-giflib5.patch
+c34a57b7d8526ee17ebfc4b472867930 imlib2-giflib5.patch
2f12454f23a8d8a867577f6bee5c29df remove-my_libs.patch"
sha256sums="af51be727d62cfcff7457c753f355e44848fb997f33a7e1d43775276a9073274 imlib2-1.4.6.tar.bz2
-1b3ee77da360d072fa6a2d6b5a1198fcb53dbb07488b38d1ee013c68dc455aad imlib2-giflib5.patch
+2dd0f75ac2a45fc0cf435951e69093a7ed56aa29bdc5603c434f40c3340210ce imlib2-giflib5.patch
5117e9a7f9d1ea44ef468fa4d13baf80c46c60ad07abb4d4900bc2c256a00906 remove-my_libs.patch"
sha512sums="50d9f16eb09029c127c2ea904d59c46dceefabec7cf2aeb05a6cec7bfd9886f01fee863958c209cbdb7fe7991e0b6a883e5d910c9c2bf2991038719aa8687787 imlib2-1.4.6.tar.bz2
-7a99f7d59f320f02119411a5a078679ef4a549700fbcfe5987e1bc3e79787c6ea65e7779883b8e2b686bfae87827408fce7de1669ac97ea1db8612fca3202870 imlib2-giflib5.patch
+e7742900e45c13af2a9947866b69c404350d0e545a9924a39b0b58eb8527ce8194f43989f2de3cb0bf4e5e82f3d22ce8a6e88aedea6e6acf21d3206f20111e54 imlib2-giflib5.patch
e4fdc734f00f9b85c84517802502c482c78132f2badc800cb8c08c851c7535556ded0c011515f669599ee6b8aa10096c58cd5cf64257f341b5c943dd1e07448e remove-my_libs.patch"
diff --git a/main/imlib2/imlib2-giflib5.patch b/main/imlib2/imlib2-giflib5.patch
index 5a7b38d134b..1bd8627d380 100644
--- a/main/imlib2/imlib2-giflib5.patch
+++ b/main/imlib2/imlib2-giflib5.patch
@@ -1,14 +1,64 @@
---- a/src/modules/loaders/loader_gif.c.orig
-+++ b/src/modules/loaders/loader_gif.c
-@@ -40,7 +40,11 @@ load(ImlibImage * im, ImlibProgressFunct
+diff -ruN imlib2-1.4.6.orig/src/modules/loaders/loader_gif.c imlib2-1.4.6/src/modules/loaders/loader_gif.c
+--- imlib2-1.4.6.orig/src/modules/loaders/loader_gif.c 2013-12-21 10:16:10.000000000 +0000
++++ imlib2-1.4.6/src/modules/loaders/loader_gif.c 2014-05-27 09:52:35.857291512 +0000
+@@ -36,7 +36,7 @@
#endif
if (fd < 0)
return 0;
-+#if defined(GIFLIB_MAJOR) && (GIFLIB_MAJOR >= 5)
+- gif = DGifOpenFileHandle(fd);
+ gif = DGifOpenFileHandle(fd, NULL);
-+#else
- gif = DGifOpenFileHandle(fd);
-+#endif
if (!gif)
{
close(fd);
+@@ -60,13 +60,13 @@
+ h = gif->Image.Height;
+ if (!IMAGE_DIMENSIONS_OK(w, h))
+ {
+- DGifCloseFile(gif);
++ DGifCloseFile(gif, NULL);
+ return 0;
+ }
+ rows = malloc(h * sizeof(GifRowType *));
+ if (!rows)
+ {
+- DGifCloseFile(gif);
++ DGifCloseFile(gif, NULL);
+ return 0;
+ }
+ for (i = 0; i < h; i++)
+@@ -78,7 +78,7 @@
+ rows[i] = malloc(w * sizeof(GifPixelType));
+ if (!rows[i])
+ {
+- DGifCloseFile(gif);
++ DGifCloseFile(gif, NULL);
+ for (i = 0; i < h; i++)
+ {
+ if (rows[i])
+@@ -150,7 +150,7 @@
+ im->data = (DATA32 *) malloc(sizeof(DATA32) * w * h);
+ if (!im->data)
+ {
+- DGifCloseFile(gif);
++ DGifCloseFile(gif, NULL);
+ free(rows);
+ return 0;
+ }
+@@ -181,7 +181,7 @@
+ last_per = (int)per;
+ if (!(progress(im, (int)per, 0, last_y, w, i)))
+ {
+- DGifCloseFile(gif);
++ DGifCloseFile(gif, NULL);
+ for (i = 0; i < h; i++)
+ {
+ free(rows[i]);
+@@ -198,7 +198,7 @@
+ {
+ progress(im, 100, 0, last_y, w, h);
+ }
+- DGifCloseFile(gif);
++ DGifCloseFile(gif, NULL);
+ for (i = 0; i < h; i++)
+ {
+ free(rows[i]);