aboutsummaryrefslogtreecommitdiffstats
path: root/main/iperf/APKBUILD
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-01-22 13:42:47 -0600
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 10:52:06 +0000
commit30275f31cdcf376e1be5fcc05c56b93ad8642719 (patch)
tree0d3203b6ac97d2f3c17a90016bdd56105da152a4 /main/iperf/APKBUILD
parent50eda18236e9b4c4014f55ee0965e134bd24234f (diff)
main/iperf: upgrade to 2.0.13
Diffstat (limited to 'main/iperf/APKBUILD')
-rw-r--r--main/iperf/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/main/iperf/APKBUILD b/main/iperf/APKBUILD
index ead2632360f..008d1ba2d97 100644
--- a/main/iperf/APKBUILD
+++ b/main/iperf/APKBUILD
@@ -1,15 +1,14 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iperf
-pkgver=2.0.10
-pkgrel=1
+pkgver=2.0.13
+pkgrel=0
pkgdesc="A tool to measure IP bandwidth using UDP or TCP"
url="http://iperf2.sourceforge.net/"
arch="all"
license="BSD"
-options="!check" # No test suite
depends="!iperf3"
-makedepends=""
subpackages="$pkgname-doc $pkgname-openrc"
source="https://sourceforge.net/projects/iperf2/files/iperf-$pkgver.tar.gz
iperf.initd
@@ -29,6 +28,12 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ # iperf -v returns 1
+ ./src/iperf -v || test $? = 1
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
@@ -36,6 +41,6 @@ package() {
install -D -m0644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="74bf49133cd123243c179e174cbaa7d2f74ca9fb47c80ca2c88b2e68ce8bca0a73709e51b3aac6bd85b8c70483b70f33e8a2424e7e0e5922397967330f7e2ecc iperf-2.0.10.tar.gz
+sha512sums="ac44ac318780cde24f667f2caad714402eade6a46943b01b5b5725d02b111a0ebbb62b376cd92afd8b3066cee725b8322cbfcec8e382eb94ee1f3cdc1112f419 iperf-2.0.13.tar.gz
339fb04b41cce11e8ea8694d95c13af9c88e0d1143356d913ec810c9b11efa27212d585b5dcc49cc2eb860a6d8bc557092c8659d7d5cfe532c5afdb36f8eedf8 iperf.initd
fb5e155fff568a72488cc1511d30358835a48bcce309f8f46d040160932b4a4ccb85040c27c60dee477900a25bd34c50eac21d1d0bea984b40faa401be2ba7e8 iperf.confd"