summaryrefslogtreecommitdiffstats
path: root/main/iproute2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/iproute2
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/iproute2')
-rw-r--r--main/iproute2/APKBUILD29
-rw-r--r--main/iproute2/iproute2.post-deinstall4
-rw-r--r--main/iproute2/iproute2.post-install6
3 files changed, 39 insertions, 0 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
new file mode 100644
index 00000000000..93f0adad226
--- /dev/null
+++ b/main/iproute2/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iproute2
+pkgver=2.6.29.1
+_realver=2.6.29-1
+pkgrel=0
+pkgdesc="IP Routing Utilities"
+url="http://www.linux-foundation.org/en/Net:Iproute2"
+license="GPL2"
+depends=
+install="$pkgname.post-install $pkgname.post-deinstall"
+makedepends="bison flex bash"
+subpackages="$pkgname-doc"
+source="http://devresources.linux-foundation.org/dev/iproute2/download/$pkgname-$_realver.tar.bz2
+ $install"
+
+build() {
+ cd "$srcdir"/$pkgname-$_realver
+
+ sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
+ sed -i 's:/usr/local:/usr:' tc/m_ipt.c include/iptables.h || return 1
+ sed -i 's:=/share:=/usr/share:' Makefile || return 1
+
+ ./configure || return 1
+ make CCOPTS="-D_GNU_SOURCE $CFLAGS" LIBDIR=/lib || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="c1bc258a6c345905e79935ac7a3cc582 iproute2-2.6.29-1.tar.bz2
+da1571ff1c0241c5c7f333a48d908927 iproute2.post-install
+ed8271a16ef48a769c50c3b529411018 iproute2.post-deinstall"
diff --git a/main/iproute2/iproute2.post-deinstall b/main/iproute2/iproute2.post-deinstall
new file mode 100644
index 00000000000..dd117e5d80f
--- /dev/null
+++ b/main/iproute2/iproute2.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+busybox --install -s
+
diff --git a/main/iproute2/iproute2.post-install b/main/iproute2/iproute2.post-install
new file mode 100644
index 00000000000..36d567ea219
--- /dev/null
+++ b/main/iproute2/iproute2.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ "$(readlink /bin/ip)" = "/bin/busybox" ]; then
+ rm -f /bin/ip
+fi
+exit 0