aboutsummaryrefslogtreecommitdiffstats
path: root/main/iptables/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-12-21 18:29:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-03 13:03:39 +0000
commit30906484e1c47c737246d5a0d1d049deec322e35 (patch)
treec067dca459707e92f27e06c92ece583d4462a30c /main/iptables/APKBUILD
parente791aa4370f4dcb5b3e3dffbc69d3b7cc6d8a39c (diff)
main/iptables: specify license
Diffstat (limited to 'main/iptables/APKBUILD')
-rw-r--r--main/iptables/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index c24900caa60..f5fd4d77087 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -2,11 +2,11 @@
pkgname=iptables
pkgver=1.4.21
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="http://www.netfilter.org/projects/iptables/index.html"
arch="all"
-license=GPL-2
+license="GPL2+"
source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
iptables-1.4.14-musl-fixes.patch
@@ -18,8 +18,9 @@ source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
makedepends="linux-headers autoconf automake"
subpackages="ip6tables $pkgname-doc $pkgname-dev"
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
update_config_sub || return 1
local i
for i in $source; do
@@ -32,7 +33,7 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure \
--build=$CBUILD \
@@ -52,7 +53,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make -j1 install DESTDIR="$pkgdir" || return 1
rm "$pkgdir"/usr/lib/*.la || return 1