summaryrefslogtreecommitdiffstats
path: root/main/iw/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-09 07:25:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-09 07:25:04 +0000
commit29f6958bc838adab23a3c564b0218608809acc1d (patch)
treee30720da99ce846241ec733416fe57125b99b121 /main/iw/APKBUILD
parent0dcd527049087a48e81cc991f4851b7682f7ac13 (diff)
main/iw: upgrade to 0.9.20
Diffstat (limited to 'main/iw/APKBUILD')
-rw-r--r--main/iw/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/iw/APKBUILD b/main/iw/APKBUILD
index 3cce23eff1b..d5ca96452c8 100644
--- a/main/iw/APKBUILD
+++ b/main/iw/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iw
-pkgver=0.9.18
+pkgver=0.9.20
pkgrel=0
pkgdesc="nl80211 based CLI configuration utility for wireless devices"
url="http://wireless.kernel.org/en/users/Documentation/iw"
@@ -8,14 +8,19 @@ license="GPL"
depends=""
makedepends="libnl-dev"
source="http://wireless.kernel.org/download/iw/iw-$pkgver.tar.bz2
- iw-bb-install.patch
iw-git-version.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 -i "$srcdir"/iw-bb-install.patch || return 1
- patch -p1 -i "$srcdir"/iw-git-version.patch || return 1
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
}
build () {
@@ -28,6 +33,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="9734080d8a5c4b768c5e0da665a48950 iw-0.9.18.tar.bz2
-7f8cfc205fdcfd49d04c8923c76f439a iw-bb-install.patch
+md5sums="1055799b544b3e08169d155bb6c21bb0 iw-0.9.20.tar.bz2
779d0e73df6e484c071149c9fb720551 iw-git-version.patch"