aboutsummaryrefslogtreecommitdiffstats
path: root/main/jbig2dec
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-21 08:10:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-21 08:27:04 +0100
commit77da6c3e8e001c9902ef2a34db72bdde47ae8c9e (patch)
treee45429e3df49486f500510bc9fc4504134f02ffd /main/jbig2dec
parent15f290c5527418c9f83f25241dd087ef9c8cb0aa (diff)
main/jbig2dec: disable tests
They require python2 to run
Diffstat (limited to 'main/jbig2dec')
-rw-r--r--main/jbig2dec/APKBUILD11
1 files changed, 1 insertions, 10 deletions
diff --git a/main/jbig2dec/APKBUILD b/main/jbig2dec/APKBUILD
index 30470f2a9e3..5978a48ca6f 100644
--- a/main/jbig2dec/APKBUILD
+++ b/main/jbig2dec/APKBUILD
@@ -5,24 +5,21 @@ pkgver=0.17
_gsver="gs950"
pkgrel=0
pkgdesc="JBIG2 image compression format decoder"
+options="!check" # Tests require python2
url="https://jbig2dec.com/"
arch="all"
license="GPL-2.0-or-later"
makedepends="autoconf automake libtool"
-checkdepends="python2"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/$_gsver/jbig2dec-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,13 +32,7 @@ build() {
make
}
-check() {
- cd "$builddir"
- make check
-}
-
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}