aboutsummaryrefslogtreecommitdiffstats
path: root/main/kamailio/APKBUILD
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2017-04-26 16:20:35 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-26 20:33:56 +0000
commitbfd677a2cbcb1b3fd3ae72e8fd40eb6b3014e3f2 (patch)
treeea9e69c0bce15fe83e01c8ec16635075f9e421d1 /main/kamailio/APKBUILD
parentd5409f57dd274647052e4a4d2057e1232a2a36a6 (diff)
main/kamailio
version bump to 5.0.1 Removed building the tls subpackage because kamailio does not work with libressl
Diffstat (limited to 'main/kamailio/APKBUILD')
-rw-r--r--main/kamailio/APKBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/main/kamailio/APKBUILD b/main/kamailio/APKBUILD
index 7dc5709cf7e..0049fbe3686 100644
--- a/main/kamailio/APKBUILD
+++ b/main/kamailio/APKBUILD
@@ -12,8 +12,8 @@ _giturl="git://github.com/$pkgname/$pkgname.git"
_gittag=HEAD
-pkgver=5.0.0
-pkgrel=1
+pkgver=5.0.1
+pkgrel=0
[ -z "${_gitcommit}" ] && _suffix="_src" || _suffix="-${_gitcommit}"
pkgdesc="Open Source SIP Server"
@@ -224,9 +224,13 @@ _module_group_kstandard="$_mod_list_basic $_mod_list_dbuid $_mod_list_pcre"
subpackages="$pkgname-doc $pkgname-dbg"
_modules="$_module_group_kstandard"
+#
+# We do not include tls modules because the tls module does not compile against libressl
+# Once it has been properly refactored we can add it back in (2017-04-26)
+#
for _i in db postgres sqlite dbtext mysql \
cpl xml unixodbc snmpstats xmpp carrierroute \
- ldap utils tls presence lua ims outbound debugger \
+ ldap utils presence lua ims outbound debugger \
extras json websocket authephemeral \
uuid ev memcached redis geoip2 jansson \
jsdt http_async; do
@@ -264,25 +268,12 @@ prepare() {
cd "$_builddir"
default_prepare
-# sed -i \
-# -e "s:-O9 -funroll-loops:$CFLAGS:g" \
-# src/Makefile.defs \
-# || return 1
-
-# -e 's:^cfg-target.*:cfg-target = $(cfg-dir):' \
-# -e 's:^cfg-prefix.*:cfg-prefix = $(basedir):' \
-
cd utils/kamctl/
sed -i -e 's:/var/run/kamailio.pid:/var/run/kamailio/kamailio.pid:g' \
kamctl.base kamctlrc || return 1
# we actually dont need bash
sed -i -e 's:/bin/bash:/bin/sh:' kamctl kamdbctl \
|| return 1
- # Set email_address field as not required field (could be null)
-# cd dbtext/kamailio
-# sed -i -e 's:email_address(string):email_address(string,null):' subscriber \
-# || return 1
-
}
build() {
@@ -516,7 +507,7 @@ http_async() {
}
-sha512sums="686ede6afcf275b739297b322be3ac74396d3230a38a52891b03e088447f5befec07992e745a6321fc39a1bd77d57787124f655f38f75133d096f20b415b3727 kamailio-5.0.0_src.tar.gz
+sha512sums="8e30d2d615e435f51d99113823652403dd0fd874d325b7e5c0e2c6055f977ab16adc8ce9de9031c591150ee43fd1a1bfe5adb252890c14087ac1795f060fc478 kamailio-5.0.1_src.tar.gz
4371c04ffdbd876cbc8128a4ae42368be7e4783eff564bd424fd4cebba18c8841212837ce305557f4d0643f37711741d157feba8cd6d24be3e9dc6a436142110 0001-musl-fixes.patch
139fab275e7d01da85bf3422a16966165c72584122513d34b5fb3d9341c430eeb69ec5b86b82ff4acce709f5ab3f651de5954ae38ff9a256a19b22d88cfea830 0003-kamdbctl.base.patch
e60e8d41e55008f0473e4d645af3b43f2bc097e341bb3bb81daec8bc47abcd6d037cbb56082675c24ffb1c50b2eb93e3c4fc50b0dc2df9cdfe4f28ad7b9fbf9e 0004-remove-spurious-execinfo.patch