aboutsummaryrefslogtreecommitdiffstats
path: root/main/ldb/APKBUILD
diff options
context:
space:
mode:
authorStefan Reiff <kroko87@hotmail.com>2019-04-27 21:28:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-03 10:34:42 +0000
commit5f1ebcb2022c7a256a05236cfc14d51dc0eb3187 (patch)
treed79487fe3d1b64c60b87bc0b383be7bcb91a12b1 /main/ldb/APKBUILD
parenta66c5986c024dd6110f448b83dd98b99eedc43db (diff)
main/ldb: upgrade to 1.5.4 and remove python2
Diffstat (limited to 'main/ldb/APKBUILD')
-rw-r--r--main/ldb/APKBUILD31
1 files changed, 11 insertions, 20 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
index cdc76324eff..bb29b2454b8 100644
--- a/main/ldb/APKBUILD
+++ b/main/ldb/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ldb
-pkgver=1.3.8
-pkgrel=1
+pkgver=1.5.4
+pkgrel=0
pkgdesc="A schema-less, ldap like, API and database"
url="https://ldb.samba.org/"
arch="all"
license="LGPL-3.0-or-later"
-makedepends="libtirpc-dev tevent-dev py2-tevent tdb-dev py2-tdb talloc-dev
- python2-dev python3-dev popt-dev cmocka-dev"
-subpackages="$pkgname-dev py2-$pkgname:_py2 py3-$pkgname:_py3 $pkgname-tools"
+makedepends="libtirpc-dev tevent-dev py3-tevent tdb-dev py3-tdb talloc-dev
+ python3-dev popt-dev cmocka-dev docbook-xsl lmdb-dev"
+subpackages="$pkgname-dev py3-$pkgname:_py3 $pkgname-tools $pkgname-doc"
source="https://www.samba.org/ftp/pub/ldb/$pkgname-$pkgver.tar.gz
- disable-compile-error-test.patch"
+ disable-compile-error-test.patch
+ 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch"
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
@@ -27,8 +28,7 @@ build() {
--disable-rpath-install \
--builtin-libraries=replace \
--bundled-libraries=NONE \
- --with-modulesdir=/usr/lib/ldb/modules \
- --extra-python=/usr/bin/python3
+ --with-modulesdir=/usr/lib/ldb/modules
"$_waf" build
}
@@ -42,16 +42,6 @@ package() {
DESTDIR="$pkgdir" "$_waf" install
}
-_py2() {
- pkgdesc="Python 2 binding for the ldb library"
- provides="py-ldb=$pkgver-r$pkgrel" # for backward compatibility
- replaces="py-ldb" # for backward compatibility
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/libpyldb-util.so.* "$subpkgdir"/usr/lib/
-}
-
_py3() {
pkgdesc="Python 3 binding for the ldb library"
@@ -67,5 +57,6 @@ tools() {
mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
}
-sha512sums="06d1b4c2badbf0c27733a64f979c48af8b599747cef7cd7f5417cd55a76447e8f8987bd061694c5af63261fdb35433e3844122c14103d5cc8b4eaab1f4752541 ldb-1.3.8.tar.gz
-ed55d5151bbcaf5c0a1b70a1f44b461a501ad94ce02ee97e3ea10c560ce3656a190510697bbd3c5b6f70a74519bf7c0a91210bcb415ffd97d9440045e10a02e8 disable-compile-error-test.patch"
+sha512sums="fc323e4283671c14d6dd4feb7e9ca943a63a166688077dbf3591f9d957cf821f9e739869842e15ca1ec4fd3764123d5afc6f4954b1af437bd1ec54df58366a22 ldb-1.5.4.tar.gz
+ed55d5151bbcaf5c0a1b70a1f44b461a501ad94ce02ee97e3ea10c560ce3656a190510697bbd3c5b6f70a74519bf7c0a91210bcb415ffd97d9440045e10a02e8 disable-compile-error-test.patch
+619db1e1cbf991546b92cfa4fd2100a0b74f563d366981b552a9997152a98ee2c5e9029c77015ab57860d0ca48a98aa24b6e5bc1c330880cd85f39c1df811e55 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch"