summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-29 12:38:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-29 12:38:22 +0000
commit0e80482ed707ad647d66a03df710a9923ee6de22 (patch)
tree729fcce291f7476bf49663a4a6ea95900454d0b3 /main/libc0.9.32
parentf505e40e90c6b62f4a97de4041cb3335c3a7a890 (diff)
main/libc0.9.32: add utmpx and fesetround for x86_64
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch98
-rw-r--r--main/libc0.9.32/APKBUILD6
-rw-r--r--main/libc0.9.32/uclibcconfig.x86_6421
3 files changed, 104 insertions, 21 deletions
diff --git a/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch b/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch
new file mode 100644
index 00000000000..84d6a2e08b7
--- /dev/null
+++ b/main/libc0.9.32/0001-libm-x86_64-implement-fesetround.patch
@@ -0,0 +1,98 @@
+From b58032ae6a34afc1887d9a6f3d05891d0d4fdbab Mon Sep 17 00:00:00 2001
+From: Natanael Copa <natanael.copa@gmail.com>
+Date: Sun, 28 Nov 2010 12:43:33 +0000
+Subject: [PATCH] libm/x86_64: implement fesetround
+
+from glibc
+---
+ libm/x86_64/Makefile.arch | 24 +++++++++++++++++++++++
+ libm/x86_64/fesetround.c | 46 +++++++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 70 insertions(+), 0 deletions(-)
+ create mode 100644 libm/x86_64/Makefile.arch
+ create mode 100644 libm/x86_64/fesetround.c
+
+diff --git a/libm/x86_64/Makefile.arch b/libm/x86_64/Makefile.arch
+new file mode 100644
+index 0000000..e1be961
+--- /dev/null
++++ b/libm/x86_64/Makefile.arch
+@@ -0,0 +1,24 @@
++# Makefile for uClibc
++#
++# Copyright (C) 2000-2008 Erik Andersen <andersen@uclibc.org>
++#
++# Licensed under the LGPL v2.1, see the file COPYING.LIB in this tarball.
++#
++# The routines included in this math library are derived from
++# glibc's libm.
++#
++
++ifeq ($(UCLIBC_HAS_FENV),y)
++libm_ARCH_SRC:=$(wildcard $(libm_ARCH_DIR)/*.c)
++libm_ARCH_OBJ:=$(patsubst $(libm_ARCH_DIR)/%.c,$(libm_ARCH_OUT)/%.o,$(libm_ARCH_SRC))
++endif
++
++libm_ARCH_OBJS:=$(libm_ARCH_OBJ)
++
++ifeq ($(DOPIC),y)
++libm-a-y+=$(libm_ARCH_OBJS:.o=.os)
++else
++libm-a-y+=$(libm_ARCH_OBJS)
++endif
++libm-so-y+=$(libm_ARCH_OBJS:.o=.os)
++
+diff --git a/libm/x86_64/fesetround.c b/libm/x86_64/fesetround.c
+new file mode 100644
+index 0000000..3d2ef4c
+--- /dev/null
++++ b/libm/x86_64/fesetround.c
+@@ -0,0 +1,46 @@
++/* Set current rounding direction.
++ Copyright (C) 2001, 2005 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#include <fenv.h>
++
++int
++fesetround (int round)
++{
++ unsigned short int cw;
++ int mxcsr;
++
++ if ((round & ~0xc00) != 0)
++ /* ROUND is no valid rounding mode. */
++ return 1;
++
++ /* First set the x87 FPU. */
++ __asm__ ("fnstcw %0" : "=m" (*&cw));
++ cw &= ~0xc00;
++ cw |= round;
++ __asm__ ("fldcw %0" : : "m" (*&cw));
++
++ /* And now the MSCSR register for SSE, the precision is at different bit
++ positions in the different units, we need to shift it 3 bits. */
++ __asm__ ("stmxcsr %0" : "=m" (*&mxcsr));
++ mxcsr &= ~ 0x6000;
++ mxcsr |= round << 3;
++ __asm__ ("ldmxcsr %0" : : "m" (*&mxcsr));
++
++ return 0;
++}
+--
+1.7.3.2
+
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 98f96f25ddf..00b7046811c 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=1011291225
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=0
+pkgrel=1
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -26,6 +26,7 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
1.patch
2.patch
0001-libc-fix-strtoq.patch
+ 0001-libm-x86_64-implement-fesetround.patch
uclibcconfig.x86
uclibcconfig.x86_64
uclibcconfig.i486
@@ -124,6 +125,7 @@ md5sums="66220e34b070d7f9fc666f88956f4ef3 libc0.9.32-0.9.32_alpha0_git101129122
8f55efc31c41bf70d99006a7d2f7fe1e 1.patch
350a608e3d3b148af882f6e074225465 2.patch
8064fe87497342a3ab4d8d8df7acc8c6 0001-libc-fix-strtoq.patch
+e0c901502602f7e9e002d910d0f32ab9 0001-libm-x86_64-implement-fesetround.patch
145aaeb1833159397cfac9902e3877ab uclibcconfig.x86
-da650c2c6a82e0b153e96774da388935 uclibcconfig.x86_64
+cb1bcf2ff83029b6943d4799d926932b uclibcconfig.x86_64
145aaeb1833159397cfac9902e3877ab uclibcconfig.i486"
diff --git a/main/libc0.9.32/uclibcconfig.x86_64 b/main/libc0.9.32/uclibcconfig.x86_64
index c7148549347..a07766c808d 100644
--- a/main/libc0.9.32/uclibcconfig.x86_64
+++ b/main/libc0.9.32/uclibcconfig.x86_64
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Version: 0.9.32-git
-# Thu Nov 18 19:45:51 2010
+# Mon Nov 29 12:34:17 2010
#
# TARGET_alpha is not set
# TARGET_arm is not set
@@ -34,23 +34,6 @@ TARGET_x86_64=y
#
TARGET_ARCH="x86_64"
FORCE_OPTIONS_FOR_ARCH=y
-# CONFIG_GENERIC_386 is not set
-# CONFIG_386 is not set
-# CONFIG_486 is not set
-# CONFIG_586 is not set
-# CONFIG_586MMX is not set
-# CONFIG_686 is not set
-# CONFIG_PENTIUMII is not set
-# CONFIG_PENTIUMIII is not set
-# CONFIG_PENTIUM4 is not set
-# CONFIG_K6 is not set
-# CONFIG_K7 is not set
-# CONFIG_ELAN is not set
-# CONFIG_CRUSOE is not set
-# CONFIG_WINCHIPC6 is not set
-# CONFIG_WINCHIP2 is not set
-# CONFIG_CYRIXIII is not set
-# CONFIG_NEHEMIAH is not set
TARGET_SUBARCH=""
#
@@ -219,7 +202,7 @@ UCLIBC_HAS_NFTW=y
UCLIBC_HAS_FTW=y
UCLIBC_HAS_GLOB=y
UCLIBC_HAS_GNU_GLOB=y
-# UCLIBC_HAS_UTMPX is not set
+UCLIBC_HAS_UTMPX=y
#
# Library Installation Options