aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpthread-stubs/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/libpthread-stubs/APKBUILD
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/libpthread-stubs/APKBUILD')
-rw-r--r--main/libpthread-stubs/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
index 30a2d9159cd..1c6c100216f 100644
--- a/main/libpthread-stubs/APKBUILD
+++ b/main/libpthread-stubs/APKBUILD
@@ -9,8 +9,15 @@ license="X11"
depends=
source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \