aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpthread-stubs/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-28 01:07:04 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-28 01:07:04 +0200
commit22e101fc699e3b9f5a2dc1458dd3ebe60f2c3272 (patch)
tree07792922d9d2b575a1d23182cce7e1ce4be786ef /main/libpthread-stubs/APKBUILD
parent14e1cf36ba5610c05a885d33afb06a2436c800fd (diff)
main/libpthread-stubs: modernize and fix abuild
Diffstat (limited to 'main/libpthread-stubs/APKBUILD')
-rw-r--r--main/libpthread-stubs/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
index d5106e002a3..9d9b8d0c935 100644
--- a/main/libpthread-stubs/APKBUILD
+++ b/main/libpthread-stubs/APKBUILD
@@ -6,19 +6,19 @@ pkgdesc="Pthread functions stubs for platforms missing them"
url="http://cgit.freedesktop.org/xcb/pthread-stubs"
arch="all"
license="X11"
-depends=
options="!dbg"
source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
-
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
update_config_sub
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,7 +27,8 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
+
sha512sums="c7cf63fa82ce9e8c37c6dc3b8cc30f8883655f95683c4466c54b617b086dd26a43bfa36363e47dc5730af6d59ac70443d211eb01b07d276edd144030a3580b15 libpthread-stubs-0.3.tar.bz2"