aboutsummaryrefslogtreecommitdiffstats
path: root/main/libseccomp
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-17 15:32:58 +0100
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-17 20:10:22 +0000
commitc936b4679770bd631d8054e76d4054b394ef9786 (patch)
tree53ea3644b29df0d634cfc9e27ceef35c5bfd7681 /main/libseccomp
parent211958e9cfa8f7d8c6a52e0873a595701f803361 (diff)
main/libseccomp: upgrade to 2.3.2
* Modernize abuild * Add check() function
Diffstat (limited to 'main/libseccomp')
-rw-r--r--main/libseccomp/APKBUILD36
1 files changed, 12 insertions, 24 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
index 91989608eeb..d0376df2b4b 100644
--- a/main/libseccomp/APKBUILD
+++ b/main/libseccomp/APKBUILD
@@ -1,33 +1,20 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libseccomp
-pkgver=2.3.1
+pkgver=2.3.2
pkgrel=0
-pkgdesc="An interface to the Linux Kernel's syscall filtering mechanismf"
+pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
url="https://github.com/seccomp/libseccomp"
arch="all"
license="LGPLv2.1"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers"
-install=""
+makedepends="linux-headers bash"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
remove-redefinition-prctl.patch"
-
-_builddir="$srcdir"/libseccomp-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/libseccomp-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,14 +27,15 @@ build() {
make || return 1
}
+check() {
+ cd "$builddir"
+ make check || return 1
+}
+
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="e6f3e84921ef9c2e9188681963f0943f libseccomp-2.3.1.tar.gz
-f10f467d772d6fcfbfb05e3bbba450b4 remove-redefinition-prctl.patch"
-sha256sums="ff5bdd2168790f1979e24eaa498f8606c2f2d96f08a8dc4006a2e88affa4562b libseccomp-2.3.1.tar.gz
-e133750447fcf0f84504d7dff4a915e357cfce9961576c57fe63df669f8dc58a remove-redefinition-prctl.patch"
-sha512sums="246b30e1c513d5e1fa35a47905d99036e276c1e6483a96f3e79ddca536a8c6f641c11bf324ed10c9c8d18fa27d73667c9c72fc7459f827d2883926769ac1cb45 libseccomp-2.3.1.tar.gz
+sha512sums="0864a53ba2be61d0207f7361af94bcda4acff84a1814f915e6ccb19ab24f6ccc978da0eedc5cee047fa655dc1a583e2eeb7ab985ebfc77491c6a2606727b79ec libseccomp-2.3.2.tar.gz
f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch"