aboutsummaryrefslogtreecommitdiffstats
path: root/main/libshout/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-01 14:05:20 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-01 14:05:20 +0000
commit7ebbcb3d815f69f1ee1c7f9ea1b338484de9dbf9 (patch)
tree9e0e9789b27dd8ebc60393b663b01a5145eacb4e /main/libshout/APKBUILD
parent710769d57348fec6e9f6a38d7e82920de05f3643 (diff)
main/libshout: upgrade to 2.4.2
Diffstat (limited to 'main/libshout/APKBUILD')
-rw-r--r--main/libshout/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/main/libshout/APKBUILD b/main/libshout/APKBUILD
index 65c689e3236..d6091fedb05 100644
--- a/main/libshout/APKBUILD
+++ b/main/libshout/APKBUILD
@@ -1,20 +1,16 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libshout
-pkgver=2.4.1
-pkgrel=5
+pkgver=2.4.2
+pkgrel=0
pkgdesc="Library for accessing a shoutcast/icecast server"
url="http://www.icecast.org/"
arch="all"
-options="!check" # No test suite.
license="LGPL-2.1"
-depends=
makedepends="speex-dev libtheora-dev libvorbis-dev openssl-dev"
-install=""
-subpackages="$pkgname-doc $pkgname-dev"
+subpackages="$pkgname-static $pkgname-doc $pkgname-dev"
source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
- 01-libshout-tls-compile-with-OpenSSL-1.1.0.patch
- "
+ 01-libshout-tls-compile-with-OpenSSL-1.1.0.patch"
build() {
cd "$builddir"
@@ -25,7 +21,12 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--with-openssl
- make LDFLAGS+=-lspeex
+ make LDFLAGS+=-lspeex
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
@@ -33,5 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4d4b958947e020de3330d49d39d59220fc89315f25f653a7456b9aa24ca9566fca30bb3d65e6348e79958656096b6b864ea8885157d24e55c8d84d6604670219 libshout-2.4.1.tar.gz
-af27d562fbf4f7be08317a97d69ae27d57618f4e6a5bc0131ce633b46a1a8f3cc24aa21ee12e427994d319e455afd8dbc3d061a6df6814958b9b787cfcb19ed8 01-libshout-tls-compile-with-OpenSSL-1.1.0.patch"
+sha512sums="ae4b042009887de22d105eb8238f4362f6ff51bd645fd51b5a87c4b5e3f5fdc99e9f99f85c24ae2e9d23eab92b854a7e733bf9f8cc61a8362ce984f02a014e93 libshout-2.4.2.tar.gz
+16534c0e3873075ce628a3cb14d4faf0f25cf0596e7bb1489b0ea6af89900e44cfedf0e06b2f58f1d67950904cd8f9c99fcb9d9b01df009558ed1401e2ab237e 01-libshout-tls-compile-with-OpenSSL-1.1.0.patch"