aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtheora/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-04 13:46:09 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-04 13:46:43 +0200
commit758c80e604118b7d673ef604da508b4ed14eac67 (patch)
treee9749d5ec07055ca41dfa117860de55c0cc6d7a6 /main/libtheora/APKBUILD
parent91d41614d8929270e4fe6a71af4d08aff3088fd8 (diff)
main/libtheory: fix build against new libpng and examples install
fixes #6131
Diffstat (limited to 'main/libtheora/APKBUILD')
-rw-r--r--main/libtheora/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index 712ff802f18..57dd01c7acc 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
pkgver=1.1.1
-pkgrel=11
+pkgrel=12
pkgdesc="An open video codec developed by the Xiph.org"
url="http://www.xiph.org"
arch="all"
license="custom"
subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
depends=
+depends_dev="libogg-dev"
makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool
linux-headers"
source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
@@ -18,23 +19,17 @@ source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
automake.patch
"
-depends_dev="libogg-dev"
-_builddir="$srcdir"/libtheora-$pkgver
+builddir="$srcdir"/libtheora-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- esac
- done
+ default_prepare || return 1
+ cd "$builddir"
+ sed -i 's/png_\(sizeof\)/\1/g' examples/png2theora.c || return 1
libtoolize --force && aclocal -I m4 && autoconf --force \
&& automake --force --add-missing || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -49,7 +44,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
install -m755 -d ""$pkgdir"/usr/share/licenses/$pkgname"
@@ -58,7 +53,8 @@ package() {
examples() {
pkgdesc="Example applications for libtheora"
- cd "$_builddir"/examples
+
+ cd "$builddir"/examples/.libs
install -d "$subpkgdir"/usr/bin
install -m755 dump_psnr player_example dump_video encoder_example \
"$subpkgdir"/usr/bin/