summaryrefslogtreecommitdiffstats
path: root/main/libxau/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/libxau/APKBUILD
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/libxau/APKBUILD')
-rw-r--r--main/libxau/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/libxau/APKBUILD b/main/libxau/APKBUILD
new file mode 100644
index 00000000000..c6b79906309
--- /dev/null
+++ b/main/libxau/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxau
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="X11 authorisation library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends=
+makedepends="pkgconfig xproto"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://xorg.freedesktop.org/releases/individual/lib/libXau-$pkgver.tar.bz2"
+
+depends_dev="xproto"
+
+build() {
+ cd "$srcdir"/libXau-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING || return 1
+}
+md5sums="993b3185c629e4b89401fca072dcb663 libXau-1.0.5.tar.bz2"