aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxcomposite/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/libxcomposite/APKBUILD
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/libxcomposite/APKBUILD')
-rw-r--r--main/libxcomposite/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/libxcomposite/APKBUILD b/main/libxcomposite/APKBUILD
index 1b891c4b49b..eda8a5bd45b 100644
--- a/main/libxcomposite/APKBUILD
+++ b/main/libxcomposite/APKBUILD
@@ -8,11 +8,17 @@ arch="all"
license="custom"
subpackages="$pkgname-dev $pkgname-doc"
depends=
+depends_dev="xproto compositeproto libxfixes-dev libx11-dev libxext-dev"
makedepends="pkgconfig libxfixes-dev libxext-dev compositeproto"
source="http://xorg.freedesktop.org//releases/individual/lib/libXcomposite-$pkgver.tar.bz2"
-depends_dev="xproto compositeproto libxfixes-dev libx11-dev libxext-dev"
_builddir="$srcdir"/libXcomposite-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
cd "$_builddir"
./configure \