aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxdmcp/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/libxdmcp/APKBUILD
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/libxdmcp/APKBUILD')
-rw-r--r--main/libxdmcp/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/libxdmcp/APKBUILD b/main/libxdmcp/APKBUILD
index b63883dd0e0..e269ab340f6 100644
--- a/main/libxdmcp/APKBUILD
+++ b/main/libxdmcp/APKBUILD
@@ -11,8 +11,15 @@ makedepends="xproto pkgconfig"
subpackages="$pkgname-dev"
source="http://xorg.freedesktop.org/releases/individual/lib/libXdmcp-$pkgver.tar.bz2"
+_builddir="$srcdir/libXdmcp-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/libXdmcp-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \