aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxdmcp/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-17 04:04:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:53:39 +0000
commit1b59d4ef6c5afea29c276da23f94086100ba4783 (patch)
tree4823e0890c064cf86ffacd018d5f63d21d899856 /main/libxdmcp/APKBUILD
parent8d2ea1b5d6596c1c85246e63ef7a5992dbc8e940 (diff)
main/libxdmcp: add test suite, modernise, add build deps
Diffstat (limited to 'main/libxdmcp/APKBUILD')
-rw-r--r--main/libxdmcp/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/main/libxdmcp/APKBUILD b/main/libxdmcp/APKBUILD
index 3a09a0c34af..32a96f928f9 100644
--- a/main/libxdmcp/APKBUILD
+++ b/main/libxdmcp/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxdmcp
pkgver=1.1.2
-pkgrel=3
+pkgrel=4
pkgdesc="X11 Display Manager Control Protocol library"
url="http://xorg.freedesktop.org/"
arch="all"
license="MIT"
depends=
-makedepends="xproto libbsd-dev"
+makedepends="xproto libbsd-dev util-macros xmlto"
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.x.org/releases/individual/lib/libXdmcp-$pkgver.tar.bz2"
@@ -22,13 +22,17 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc \
- || return 1
- make || return 1
+ --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$srcdir"/libXdmcp-$pkgver
- make -j1 DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
}
sha512sums="f96005934b8bc752059106f8caf7df0574f5ef3c7a83bd797497b56ca556a7ff4dc1d28195e421259e82ea027b5c738094add3ec107a22544c9070725d8d46bb libXdmcp-1.1.2.tar.bz2"