aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-grsec/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-23 11:34:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-23 11:34:24 +0000
commit673bcaeccbabdfb2cfa4ffac1d5d2d18714205d3 (patch)
treedf21e20aa6341e66cb9de4a61c925ec0cae7388a /main/linux-grsec/APKBUILD
parentb6a253b9e2c2dd7021fd1812fa81d0b49fae9056 (diff)
*/*-grsec: let mkinitfs trigger create the links
Fixes #171 also create firmware subpackage that will be used for all 2.6.30.x kernels
Diffstat (limited to 'main/linux-grsec/APKBUILD')
-rw-r--r--main/linux-grsec/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index c06a6437ed7..17752124c3a 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,20 +4,20 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.30.7
_kernver=2.6.30
-pkgrel=1
+pkgrel=2
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
-depends="mkinitfs"
+depends="mkinitfs linux-firmware"
makedepends="perl installkernel"
_config=${config:-kernelconfig}
-install="$pkgname.post-install $pkgname.post-upgrade"
+install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
grsecurity-2.1.14-2.6.30.7-200909151852.patch
net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
$_config
"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev linux-firmware:firmware"
license="GPL-2"
_abi_release=${pkgver}-${_flavor}
@@ -58,12 +58,12 @@ build() {
INSTALL_MOD_PATH="$pkgdir" \
INSTALL_PATH="$pkgdir"/boot
- ln -s vmlinuz-${_abi_release} "${pkgdir}"/boot/$_flavor
+# ln -s vmlinuz-${_abi_release} "${pkgdir}"/boot/$_flavor
rm -f "$pkgdir"/lib/modules/${_abi_release}/build \
"$pkgdir"/lib/modules/${_abi_release}/source
install -D include/config/kernel.release \
- "$pkgdir"/usr/share/$pkgname/kernel.release
+ "$pkgdir"/usr/share/kernel/$_flavor/kernel.release
}
dev() {
@@ -112,6 +112,13 @@ dev() {
"$subpkgdir"/lib/modules/${_abi_release}/build
}
+firmware() {
+ pkgdesc="Firmware for linux kernel"
+ replaces="linux-grsec linux-vserver"
+ mkdir -p "$subpkgdir"/lib
+ mv "$pkgdir"/lib/firmware "$subpkgdir"/lib/
+}
+
md5sums="7a80058a6382e5108cdb5554d1609615 linux-2.6.30.tar.bz2
7c91fa862b90d74da3aa83446d69a412 patch-2.6.30.7.bz2
414fc3d63417fc21a00ef94a611c58be grsecurity-2.1.14-2.6.30.7-200909151852.patch