aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-rpi
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-05-24 08:01:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-05-25 19:43:17 +0000
commit3d491c7d11c2856c46f397a1004c7ba47676c4d1 (patch)
tree87677708c4945413a8356b6f31a2ba7740234a5f /main/linux-rpi
parentb618160e1804a1102d017d6531c6b4ba1b11c59d (diff)
main/linux-rpi: Adds missing kernel modules for Bluetooth chipset on RPi3
This is required to hciattach the bcm43xx to the UART on the RPi3.
Diffstat (limited to 'main/linux-rpi')
-rw-r--r--main/linux-rpi/APKBUILD8
-rw-r--r--main/linux-rpi/config-rpi2.armhf13
2 files changed, 15 insertions, 6 deletions
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index 080cc4bfe2d..dc95820daf0 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -6,7 +6,7 @@ case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with Raspberry Pi patches"
url=https://github.com/raspberrypi/linux
depends="mkinitfs linux-firmware"
@@ -203,7 +203,7 @@ b66e8aa4991ca5c2ccd61559ed7e6491 gpio-mcp23s08-pullups.patch
5508d2b3e5967bd57f92f551d90b3e54 rotary-encoder-fix.patch
29281b74d2cef6965fa4ab6d826a2aa4 issue-4973.patch
488b5bf00d6d9dfc0be1a29f9ca9c37e config-rpi.armhf
-9c4a9d298f57b6fecabb8e2f2409561d config-rpi2.armhf
+e6fcd3178e3b77046cf35b77b28871ea config-rpi2.armhf
e587cae1dca2f5992555d9bcf53deecf markdt"
sha256sums="401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2 linux-4.4.tar.xz
394c3970865c092f21cd02b8f433024adbf8539114567d6bde197fed6612f553 patch-4.4.11.xz
@@ -213,7 +213,7 @@ b389a556bbd98053881b43deef1adf20640f980557c5f37cfd7ece2daeecbda9 gpio-mcp23s08-
ab6740577fe8c1d71d2c716720ebbbf9a750985963d6938093b4ca9194b6e871 rotary-encoder-fix.patch
3a16e927ce53a8c56e7f1dd86fe8ad08b1c06466f5206c521a7e2de1e4796d6c issue-4973.patch
cd0ac8a7d50fcf22594d26e06b8aa48a88b899f6bbaea69931cded65bb64dc71 config-rpi.armhf
-5f4c13e51209cf22081f13afe22489865e7d6e85bb5779f230514524f3a9dd5c config-rpi2.armhf
+df59e22f99720769b2296e1e1f117dcae37a9c6eca6bdaabed5814ee40bd4c3c config-rpi2.armhf
0f6681fc5c3590e1dbe13a2bde796403bd1529cf0fe19720899eaa0db79bcb49 markdt"
sha512sums="13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e linux-4.4.tar.xz
697e6dd2b85da13ae65ac70b9654c9c3fa00c3120d425fdb53104fc234457cda40b9f0ebe29e7ae5c1a191730666c0bbd291721b16623ee8e402287771f20def patch-4.4.11.xz
@@ -223,5 +223,5 @@ abe4d482a98450335eb935cf49be468accc8955a464553c45280f15d4114a87e96b158800536c2f6
3a711e2cdb6c0ecaceb3755437d38626dec8403e8aa167a6e16f64d8a8b7cc5bdc7e04aa7c05938719ebc90e319ec4124ee2151a7855e7838ee143b62d140ad0 rotary-encoder-fix.patch
501c91bf2538a18102da59bbccc3097f9c3c90079acc0e946ff075074160c09b8a66934e5ce5470e170f0e4f93d114709a95230367426d0bb7ea02c4bdf4cc9b issue-4973.patch
9e1e54c1a9e5a5cce72d96c875e759b1354ab8fbf4a09eeb1d21078de1b43a2d762bac6351e9df959930c0f08bf62696efb80b6cae17af7203860f62d78b6597 config-rpi.armhf
-7a9fb5d10766d72a117a305598386e7d5b6bd69d49e56d6419050f884fbf81573a5008d752f099e78519121e98beb5f6f2e359ce22509f9547ac30733b3b0654 config-rpi2.armhf
+e7cb9c2bb045a51b84dd68eddb65efe2be2645e65f869bb080994984bae8deb2db5cab2d65951d1a33919f620f6685485cf5856905a840c0d0dc5ff9e7071108 config-rpi2.armhf
a4ecd1f48db64f9d6a189250d1937d7f2cd3a049a3d24cc527d04d05db06137722f1ba44bcd6033794781c3f2cfe2fbe065410a16de4bfdf4b1cd95d89322a77 markdt"
diff --git a/main/linux-rpi/config-rpi2.armhf b/main/linux-rpi/config-rpi2.armhf
index 9a2a87aa1e0..008e4937a5f 100644
--- a/main/linux-rpi/config-rpi2.armhf
+++ b/main/linux-rpi/config-rpi2.armhf
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.4.10 Kernel Configuration
+# Linux/arm 4.4.11 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1176,8 +1176,17 @@ CONFIG_BT_HCIBTUSB=m
CONFIG_BT_HCIBTUSB_BCM=y
CONFIG_BT_HCIBTUSB_RTL=y
# CONFIG_BT_HCIBTSDIO is not set
-# CONFIG_BT_HCIUART is not set
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIUART_H4=y
+# CONFIG_BT_HCIUART_BCSP is not set
+# CONFIG_BT_HCIUART_ATH3K is not set
+# CONFIG_BT_HCIUART_LL is not set
+# CONFIG_BT_HCIUART_3WIRE is not set
+# CONFIG_BT_HCIUART_INTEL is not set
+CONFIG_BT_HCIUART_BCM=y
+# CONFIG_BT_HCIUART_QCA is not set
CONFIG_BT_HCIBCM203X=m
+# CONFIG_BT_HCIBPA10X is not set
CONFIG_BT_HCIBFUSB=m
CONFIG_BT_HCIVHCI=m
CONFIG_BT_MRVL=m