summaryrefslogtreecommitdiffstats
path: root/main/lockfile-progs
diff options
context:
space:
mode:
authorDuane Hughes <duanejevon@gmail.com>2011-03-22 08:30:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-22 21:03:30 +0000
commit019aab029adea34f90f2811556b8df162c3e7b46 (patch)
treeae83fe79babb2df7f6a7d658afe1fde6bbd5ef67 /main/lockfile-progs
parentacdd8885dd810ddcea0f0dc77b9cb34e66c97709 (diff)
main/{liblockfile|logcheck|lockfile-progs}: moving to main branch
verified operation, moving to main repo
Diffstat (limited to 'main/lockfile-progs')
-rw-r--r--main/lockfile-progs/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/lockfile-progs/APKBUILD b/main/lockfile-progs/APKBUILD
new file mode 100644
index 00000000000..a1c5aad9f83
--- /dev/null
+++ b/main/lockfile-progs/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Duane Hughes <duanejevon@gmail.com
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lockfile-progs
+pkgver=0.1.15
+pkgrel=0
+pkgdesc="Programs for locking and unlocking files and mailboxes"
+url="http://packages.debian.org/sid/lockfile-progs"
+arch="all"
+license="GPL"
+depends="liblockfile"
+makedepends="liblockfile-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/l/lockfile-progs/${pkgname}_$pkgver.tar.gz"
+
+_builddir="$srcdir"/sid
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/share/man
+ install -m 755 "$_builddir"/bin/* "$pkgdir"/usr/bin
+ install -m 644 "$_builddir"/man/* "$pkgdir"/usr/share/man
+}
+
+md5sums="abfcda83a1868073673f4d78066b8f8a lockfile-progs_0.1.15.tar.gz"