summaryrefslogtreecommitdiffstats
path: root/main/logrotate
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 17:58:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 18:07:05 +0000
commit689d64cdc3736bb3e965f5b0181b1db77c7d3240 (patch)
treec67d91be54b3f9be5a70ab5223681edb66334de1 /main/logrotate
parent1b9e680cbcfb76b84ef02c9f552c850d0ef856c7 (diff)
main/logrotate: install cron script in /etc/periodic/daily
fixes #83 also create a working default config
Diffstat (limited to 'main/logrotate')
-rw-r--r--main/logrotate/APKBUILD15
-rw-r--r--main/logrotate/logrotate.conf20
2 files changed, 29 insertions, 6 deletions
diff --git a/main/logrotate/APKBUILD b/main/logrotate/APKBUILD
index e29b27e1eab..6881d4c2249 100644
--- a/main/logrotate/APKBUILD
+++ b/main/logrotate/APKBUILD
@@ -1,14 +1,16 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=logrotate
pkgver=3.7.8
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to rotate logfiles"
url="https://fedorahosted.org/logrotate/"
license="GPL"
-depends="uclibc popt"
+depends=
makedepends="popt-dev wget"
subpackages="$pkgname-doc"
-source="https://fedorahosted.org/releases/l/o/logrotate/logrotate-3.7.8.tar.gz"
+source="https://fedorahosted.org/releases/l/o/logrotate/logrotate-3.7.8.tar.gz
+ logrotate.conf"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -16,8 +18,9 @@ build() {
make || return 1
install -Dm755 logrotate "$pkgdir"/usr/sbin/logrotate
install -Dm644 logrotate.8 "$pkgdir"/usr/share/man/man8/logrotate.8
- install -Dm644 examples/logrotate-default "$pkgdir"/etc/logrotate.conf
- install -Dm644 examples/logrotate.cron "$pkgdir"/etc/logrotate.cron
+ install -Dm644 ../logrotate.conf "$pkgdir"/etc/logrotate.conf
+ install -Dm755 examples/logrotate.cron "$pkgdir"/etc/periodic/daily/logrotate
}
-md5sums="b3589bea6d8d5afc8a84134fddaae973 logrotate-3.7.8.tar.gz"
+md5sums="b3589bea6d8d5afc8a84134fddaae973 logrotate-3.7.8.tar.gz
+fef6415a79a6fede8cf9b9b6b8410090 logrotate.conf"
diff --git a/main/logrotate/logrotate.conf b/main/logrotate/logrotate.conf
new file mode 100644
index 00000000000..125268ae80f
--- /dev/null
+++ b/main/logrotate/logrotate.conf
@@ -0,0 +1,20 @@
+# see "man logrotate" for details
+# rotate log files weekly
+weekly
+
+# keep 4 weeks worth of backlogs
+rotate 4
+
+# create new (empty) log files after rotating old ones
+create
+
+# use date as a suffix of the rotated file
+dateext
+
+# uncomment this if you want your log files compressed
+compress
+
+# apk packages drop log rotation information into this directory
+include /etc/logrotate.d
+
+# system-specific logs may be also be configured here.