aboutsummaryrefslogtreecommitdiffstats
path: root/main/loudmouth
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-05-30 06:06:08 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-03 03:43:35 +0000
commit9e81708c1806fe79ce8eaddc2f975e8ce9a9cad0 (patch)
tree15a4143a5955d9435dd146f1d11c8480a076ebd5 /main/loudmouth
parentc216cfba193fb0ff74fbd2bf76a1d6b979aa93d2 (diff)
main/loudmouth: upgrade to 1.5.3
Diffstat (limited to 'main/loudmouth')
-rw-r--r--main/loudmouth/01-fix-sasl-md5-digest-uri.patch25
-rw-r--r--main/loudmouth/03-drop-stanzas-on-fail.patch46
-rw-r--r--main/loudmouth/04-use-pkg-config-for-gnutls.patch24
-rw-r--r--main/loudmouth/APKBUILD51
-rw-r--r--main/loudmouth/gnutls-3.4.0.patch20
-rw-r--r--main/loudmouth/loudmouth-1.4.3-glib-compile-fix.patch17
6 files changed, 12 insertions, 171 deletions
diff --git a/main/loudmouth/01-fix-sasl-md5-digest-uri.patch b/main/loudmouth/01-fix-sasl-md5-digest-uri.patch
deleted file mode 100644
index 872d93553b7..00000000000
--- a/main/loudmouth/01-fix-sasl-md5-digest-uri.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/loudmouth/lm-connection.c b/loudmouth/lm-connection.c
-index 21c1bc2..ae8de94 100644
---- a/loudmouth/lm-connection.c
-+++ b/loudmouth/lm-connection.c
-@@ -1441,11 +1441,18 @@ lm_connection_authenticate (LmConnection *connection,
- connection->effective_jid = g_strdup_printf ("%s/%s",
- connection->jid, connection->resource);
-
- if (connection->use_sasl) {
-+ gchar *domain = NULL;
-+
-+ if (!connection_get_server_from_jid (connection->jid, &domain)) {
-+ domain = g_strdup (connection->server);
-+ }
-+
- lm_sasl_authenticate (connection->sasl,
- username, password,
-- connection->server,
-+ domain,
- connection_sasl_auth_finished);
-+ g_free (domain);
-
- connection->features_cb =
- lm_message_handler_new (connection_features_cb,
-
diff --git a/main/loudmouth/03-drop-stanzas-on-fail.patch b/main/loudmouth/03-drop-stanzas-on-fail.patch
deleted file mode 100644
index 05f4248de02..00000000000
--- a/main/loudmouth/03-drop-stanzas-on-fail.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From: Sjoerd Simons <sjoerd.simons@collabora.co.uk>
-Date: Tue, 13 Jan 2009 11:28:44 +0000
-Subject: [PATCH] Drop stanzas when failing to convert them to LmMessages
-
-when a stanza comes in that for some reason can't be parsed into an LmMessage,
-just drop them on the floor instead of blocking the parser. I've seen this
-issue happen in practise because some (buggy?) client sending an iq with a
-prefix e.g. <client:iq xmlns:client="jabber:client" ... />
----
- loudmouth/lm-parser.c | 15 ++++++---------
- 1 files changed, 6 insertions(+), 9 deletions(-)
-
-diff --git a/loudmouth/lm-parser.c b/loudmouth/lm-parser.c
-index 1938d56..89f6675 100644
---- a/loudmouth/lm-parser.c
-+++ b/loudmouth/lm-parser.c
-@@ -151,19 +151,16 @@ parser_end_node_cb (GMarkupParseContext *context,
- if (!m) {
- g_warning ("Couldn't create message: %s\n",
- parser->cur_root->name);
-- return;
-- }
--
-- g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_PARSER,
-+ } else {
-+ g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_PARSER,
- "Have a new message\n");
-- if (parser->function) {
-- (* parser->function) (parser, m, parser->user_data);
-+ if (parser->function) {
-+ (* parser->function) (parser, m, parser->user_data);
-+ }
-+ lm_message_unref (m);
- }
-
-- lm_message_unref (m);
- lm_message_node_unref (parser->cur_root);
--
--
- parser->cur_node = parser->cur_root = NULL;
- } else {
- LmMessageNode *tmp_node;
---
-1.5.6.5
-
-
diff --git a/main/loudmouth/04-use-pkg-config-for-gnutls.patch b/main/loudmouth/04-use-pkg-config-for-gnutls.patch
deleted file mode 100644
index eecd4198711..00000000000
--- a/main/loudmouth/04-use-pkg-config-for-gnutls.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Description: use pkg-config to detect gnutls
-Debian: http://bugs.debian.org/529835
-Origin: http://groups.google.com/group/loudmouth-dev/browse_thread/thread/3f78255837048daf#
-
---- a/configure.ac.orig 2009-08-16 20:29:36.000000000 +0200
-+++ b/configure.ac 2009-08-16 20:30:43.000000000 +0200
-@@ -146,10 +146,12 @@ AC_ARG_WITH(openssl-libs,
- enable_ssl=no
- if test "x$ac_ssl" = "xgnutls"; then
- dnl Look for GnuTLS
-- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
-- if test "x$have_libgnutls" = "xyes"; then
-- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
-- LIBS="$LIBS $LIBGNUTLS_LIBS"
-+ PKG_CHECK_MODULES(GNUTLS, gnutls >= $GNUTLS_REQUIRED, have_gnutls=yes, have_gnutls=no)
-+ if test "x$have_gnutls" = "xyes"; then
-+ AC_SUBST(ASYNCNS_CFLAGS)
-+ AC_SUBST(ASYNCNS_LIBS)
-+ CFLAGS="$CFLAGS $GNUTLS_CFLAGS"
-+ LIBS="$LIBS $GNUTLS_LIBS"
- AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
- enable_ssl=GnuTLS
- else
-
diff --git a/main/loudmouth/APKBUILD b/main/loudmouth/APKBUILD
index 9d7ed203dec..be795e5a517 100644
--- a/main/loudmouth/APKBUILD
+++ b/main/loudmouth/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=loudmouth
-pkgver=1.4.3
-pkgrel=4
+pkgver=1.5.3
+pkgrel=0
pkgdesc="A lightweight Jabber client library"
url="http://groups.google.com/group/loudmouth-dev"
arch="all"
@@ -12,28 +12,15 @@ depends_dev="pkgconfig gnutls-dev libidn-dev libasyncns-dev check-dev autoconf"
makedepends="$depends_dev glib-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.gnome.org/pub/gnome/sources/${pkgname}/1.4/${pkgname}-${pkgver}.tar.bz2
- 01-fix-sasl-md5-digest-uri.patch
- 03-drop-stanzas-on-fail.patch
- 04-use-pkg-config-for-gnutls.patch
- loudmouth-1.4.3-glib-compile-fix.patch
- gnutls-3.4.0.patch
- "
-_builddir="$srcdir"/$pkgname-$pkgver
+source="https://mcabber.com/files/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare || return
}
build() {
- cd "$_builddir"
+ cd "$builddir"
autoconf
./configure \
--build=$CBUILD \
@@ -41,34 +28,20 @@ build() {
--disable-static \
--with-asyncns=yes \
--prefix=/usr \
- --with-libgnutls-prefix=/usr \
--infodir=/usr/share/info \
--localstatedir=/var \
|| return 1
make || return 1
+}
+
+check() {
+ cd "$builddir"
make check || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="55339ca42494690c3942ee1465a96937 loudmouth-1.4.3.tar.bz2
-5a860172e76dc5df8e694602f360ce76 01-fix-sasl-md5-digest-uri.patch
-d0f34028837b7ff93262373ac3d4dd59 03-drop-stanzas-on-fail.patch
-2cfb0ef5c32c9bd377e3abb6ad38135a 04-use-pkg-config-for-gnutls.patch
-48d26a95b653a8b0bb5589a3c674a58b loudmouth-1.4.3-glib-compile-fix.patch
-8c0b4d052f2be41f3c984da97786eafe gnutls-3.4.0.patch"
-sha256sums="95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3 loudmouth-1.4.3.tar.bz2
-5f781d15fb0b5598fb1bc16933cef1a9f006ba8cfa16a6845209b88c68b8dc16 01-fix-sasl-md5-digest-uri.patch
-21f9562965ad49ddd12b76b5eaff79a73ff1a35256cd34747b4d4b29de34f330 03-drop-stanzas-on-fail.patch
-d06d5b1d70efb061d6cfec5db918b3585cadf3d07aa8b2bdcfdb5667cfdd086d 04-use-pkg-config-for-gnutls.patch
-543b4a18b7dd1bff15b4113aa3875596d2d274bb982f1d1aa2582dbaf11f9ab4 loudmouth-1.4.3-glib-compile-fix.patch
-2297b56c9cb41b3922b0de26ec0e96f85d5d6397d8ad39bc0f8927c9b267a105 gnutls-3.4.0.patch"
-sha512sums="02d1de14a4d626a4c9100bd24c06d4b4203eabb0f95bab40ee18ea5e68ed81d47aa977625140157b2d9f7974ac748af857c2ee3a916f0db700e2a2d0934940ec loudmouth-1.4.3.tar.bz2
-81302ac124207983ee35fc80e6dc1c0686b2d8d2cde905122f8611a5ffa8affe8625ad11af2f4e49c183a89ea7c6b43976af175bfda4490cbc90461ff5436fca 01-fix-sasl-md5-digest-uri.patch
-7b20b8897b9572f2be875b4e29dbf5f6d6278db6cc5cc0017e68ce3a27af41e50bd659bfa26c8d91de221ac55cbe5497ab1f5f6be541b21fe469a321904145ab 03-drop-stanzas-on-fail.patch
-d05ebc1bcef6fa40f4dfd3bf294005b9c261df7b8f2ff5c410954541af37227de884259e49a42f3df84889bd839a32560d67c3adec1940592f89b7dba6388a56 04-use-pkg-config-for-gnutls.patch
-224402461872f9fe24826307221f7e81f211a2d720559545d4cf2355cd2aacdebd82f47b74948eb3d63fc68a0371e8477b800578b748ec56043a496398880da1 loudmouth-1.4.3-glib-compile-fix.patch
-6bda76bfd91ec82c5cb9af2231e2fb9fda134643fcd2e08b19e91c7bbbd59634363258f64f93d612c377a06dce4808b9d62dbfb30ebc56ef84c2363ff979dd30 gnutls-3.4.0.patch"
+sha512sums="ab6b16b4e644b69cdb7d8df1753d1bb5b43c2f1e76944e639339169b332e1b5c6a4246053c5b8a579ee9b53c845cef610b0040dfdffeb857180b6bab71adfcce loudmouth-1.5.3.tar.bz2"
diff --git a/main/loudmouth/gnutls-3.4.0.patch b/main/loudmouth/gnutls-3.4.0.patch
deleted file mode 100644
index 4f2e8c6f4d2..00000000000
--- a/main/loudmouth/gnutls-3.4.0.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/loudmouth/lm-ssl-gnutls.c 2008-10-29 14:45:10.000000000 +0100
-+++ b/loudmouth/lm-ssl-gnutls.c.new 2015-04-17 22:35:06.703672306 +0200
-@@ -196,17 +196,9 @@
- {
- int ret;
- gboolean auth_ok = TRUE;
-- const int cert_type_priority[] =
-- { GNUTLS_CRT_X509, GNUTLS_CRT_OPENPGP, 0 };
-- const int compression_priority[] =
-- { GNUTLS_COMP_DEFLATE, GNUTLS_COMP_NULL, 0 };
-
- gnutls_init (&ssl->gnutls_session, GNUTLS_CLIENT);
- gnutls_set_default_priority (ssl->gnutls_session);
-- gnutls_certificate_type_set_priority (ssl->gnutls_session,
-- cert_type_priority);
-- gnutls_compression_set_priority (ssl->gnutls_session,
-- compression_priority);
- gnutls_credentials_set (ssl->gnutls_session,
- GNUTLS_CRD_CERTIFICATE,
- ssl->gnutls_xcred);
diff --git a/main/loudmouth/loudmouth-1.4.3-glib-compile-fix.patch b/main/loudmouth/loudmouth-1.4.3-glib-compile-fix.patch
deleted file mode 100644
index 03d04e78a3d..00000000000
--- a/main/loudmouth/loudmouth-1.4.3-glib-compile-fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix compile against new glib.
-
-From: Daniel Drake <dsd@laptop.org>
-
-Index: loudmouth-1.4.3/loudmouth/lm-error.c
-===================================================================
---- loudmouth-1.4.3.orig/loudmouth/lm-error.c
-+++ loudmouth-1.4.3/loudmouth/lm-error.c
-@@ -19,7 +19,7 @@
- */
-
- #include <config.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include "lm-error.h"
-
- /**