summaryrefslogtreecommitdiffstats
path: root/main/lua-alt-getopt/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-04 21:48:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-04 21:48:29 +0000
commitd1bd52876cb6805b6e518f2b02168dc3c352b06f (patch)
tree7164067acb1ad492d411c6b3a5527a4686dbecc0 /main/lua-alt-getopt/APKBUILD
parent4ea8e8dad5a1f33af3b810ec6c2dbec9eab2bb92 (diff)
main/lua-alt-getopt: new aport
Lua module for processing options similar to getopt_long(3) http://luaforge.net/projects/alt-getopt/
Diffstat (limited to 'main/lua-alt-getopt/APKBUILD')
-rw-r--r--main/lua-alt-getopt/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/lua-alt-getopt/APKBUILD b/main/lua-alt-getopt/APKBUILD
new file mode 100644
index 00000000000..367097151d4
--- /dev/null
+++ b/main/lua-alt-getopt/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinlinux.org>
+pkgname=lua-alt-getopt
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="Lua module for processing options similar to getopt_long(3)"
+url="http://luaforge.net/projects/alt-getopt/"
+license="MIT"
+depends="lua"
+makedepends=
+install=
+subpackages=
+source="http://mova.org/~cheusov/pub/lua_alt_getopt/lua-alt-getopt-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm644 alt_getopt.lua "$pkgdir"/usr/share/lua/5.1/alt_getopt.lua
+}
+
+md5sums="f504578b1287ea02759add231b972812 lua-alt-getopt-0.7.0.tar.gz"