summaryrefslogtreecommitdiffstats
path: root/main/lua-pc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-07 17:37:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-07 17:37:47 +0000
commitfb325c5c69d72a9eed14cad33068153c72b60426 (patch)
tree0ef06871aec4bf00bb94043b21f30c1c4808fb25 /main/lua-pc
parent867556634decf41c9303f30cd4dc74c2da7d8f65 (diff)
main/lua-pc: renamed from lpc
Diffstat (limited to 'main/lua-pc')
-rw-r--r--main/lua-pc/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/lua-pc/APKBUILD b/main/lua-pc/APKBUILD
new file mode 100644
index 00000000000..856432058d4
--- /dev/null
+++ b/main/lua-pc/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-pc
+_name=lpc
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Lua Process Call"
+url="http://lua.net-core.org/sputnik.lua?p=Telesto:About"
+license="MIT/X11"
+makedepends="lua-dev"
+depends="lua"
+source="http://lua.net-core.org/dl/telesto/lpc-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS -shared"
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ # does not respect DESTDIR
+ make install PREFIX="$pkgdir"/usr
+}
+
+md5sums="d1516818de2d94ea0c9d748726cf0d72 lpc-1.0.0.tar.gz"