summaryrefslogtreecommitdiffstats
path: root/main/lua
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 06:53:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 06:53:19 +0000
commit13892e864cacf21636be25149eabcd3e2537f7aa (patch)
treee4cc07e4c0fef86f9e564f2226091ee4ad0c6826 /main/lua
parent12c215633f8dc3b1c4e7f1535eb741009c922c3a (diff)
main/lua: link to libpthread in case modules uses pthread
Otherwise a module thats linked to pthread will go boom. This works around the issue with luasql.sqlite3. See http://bugs.gentoo.org/show_bug.cgi?id=189804
Diffstat (limited to 'main/lua')
-rw-r--r--main/lua/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/lua/APKBUILD b/main/lua/APKBUILD
index 5e41bc03ad2..8a770eda83d 100644
--- a/main/lua/APKBUILD
+++ b/main/lua/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua
pkgver=5.1.4
-pkgrel=2
+pkgrel=3
pkgdesc="A powerful light-weight programming language designed for extending applications."
url="http://www.lua.org/"
license="MIT"
@@ -31,7 +31,7 @@ build ()
make CFLAGS=" -DLUA_USE_LINUX $CFLAGS" \
RPATH="/usr/lib" \
LUA_LIBS="-lreadline" \
- LIB_LIBS="-lm -ldl" \
+ LIB_LIBS="-lpthread -lm -ldl" \
V=$pkgver \
gentoo_all || return 1