aboutsummaryrefslogtreecommitdiffstats
path: root/main/luajit
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-05-06 19:56:16 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-05-06 19:56:16 +0300
commit36fad779c69d0d0c6d1a8fbb01beb0988b0e6a42 (patch)
treee53c98741c1a5d32f915673cd40538d45e4c6a7f /main/luajit
parent6d64b967a67a61e919dd46f57ccc915ed97fc3e8 (diff)
main/luajit: moved from testing
Diffstat (limited to 'main/luajit')
-rw-r--r--main/luajit/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/luajit/APKBUILD b/main/luajit/APKBUILD
new file mode 100644
index 00000000000..25233add2ff
--- /dev/null
+++ b/main/luajit/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=luajit
+pkgver=2.0.3
+pkgrel=1
+pkgdesc='Just-in-time compiler and replacement for Lua 5.1 '
+url='http://luajit.org'
+arch="all"
+license="MIT"
+makedepends="$depends_dev paxctl"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://luajit.org/download/LuaJIT-$pkgver.tar.gz"
+
+_builddir=$srcdir/LuaJIT-$pkgver
+
+build() {
+ cd "$_builddir"
+ make amalg PREFIX=/usr || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr || return 1
+
+ local paxflags="-m"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+ paxctl -c $paxflags "$pkgdir"/usr/bin/luajit-$pkgver || return 1
+
+ install -Dm644 "$_builddir"/COPYRIGHT \
+ $pkgdir/usr/share/licenses/$pkgname/COPYRIGHT
+}
+
+md5sums="f14e9104be513913810cd59c8c658dc0 LuaJIT-2.0.3.tar.gz"
+sha256sums="55be6cb2d101ed38acca32c5b1f99ae345904b365b642203194c585d27bebd79 LuaJIT-2.0.3.tar.gz"
+sha512sums="7b3e3de22ac3602299b5918b60801e45a3278e547a15c16fdae7359538d4ada27ba664935d5f97c7409f330c2f8efeaae9ea03415f5e9d5a9d81e022cd5d36e0 LuaJIT-2.0.3.tar.gz"