summaryrefslogtreecommitdiffstats
path: root/main/lxdm/APKBUILD
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-09-29 21:12:32 +0000
committerJeff Bilyk <jbilyk@gmail.com>2011-09-29 21:12:32 +0000
commit356b15c1862cc41d08a120ac67d4dec7f1285a38 (patch)
treee8b9064f9f188aa74ecc4a1fa0b11134a37887a5 /main/lxdm/APKBUILD
parenta86e124cf56f3ca95b15b48e3b1759f3fbdd0d7b (diff)
main/lxdm: add custom background to login screen for ticket #659
Take the custom background that was used in slim and add to the lxdm package
Diffstat (limited to 'main/lxdm/APKBUILD')
-rw-r--r--main/lxdm/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/lxdm/APKBUILD b/main/lxdm/APKBUILD
index 05f9931dc15..56754a97ef1 100644
--- a/main/lxdm/APKBUILD
+++ b/main/lxdm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=lxdm
pkgver=0.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="LXDE desktop login manager"
url="http://wiki.lxde.org/en/LXDM"
license="GPL"
@@ -10,6 +10,7 @@ depends="bash"
makedepends="autoconf automake gtk+-dev consolekit-dev"
install=
source="http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz
+ background.png
lxdm.initd
lxdm-execinfo.patch
lxdm-nopam.patch"
@@ -29,11 +30,15 @@ prepare() {
esac
done
+ # Replace the default background with the Alpine default one
+ sed -i 's/file="wave.svg"/file="background.png"/' "$_builddir"/data/themes/Industrial/gtkrc
+
autoreconf
}
build() {
cd "$_builddir"
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -47,9 +52,12 @@ package() {
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # Install the custom Alpine background
+ install -m644 -D "$srcdir"/background.png "$pkgdir"/usr/share/lxdm/themes/Industrial/background.png
}
md5sums="1d0688e088edab7c3c563263eb2f9654 lxdm-0.3.0.tar.gz
+50022ef35118455e23d4e4b8e2e912af background.png
d6455d172d5d897f6bfcefe9a1a632c7 lxdm.initd
045da38f5bb183ccacc489ea7e50e927 lxdm-execinfo.patch
0d44e8cd97894fd680e3f09e680c3481 lxdm-nopam.patch"