aboutsummaryrefslogtreecommitdiffstats
path: root/main/make/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-09-13 08:03:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-09-13 08:08:46 +0000
commitb5f861a30e4f2bea1cad2360a40c7670f75a62d0 (patch)
tree5a5dc5693742078afec2e8918e59531d5b30c33c /main/make/APKBUILD
parent4f003493b9fb59ddab02fb45308250fc691eed4a (diff)
main/make: bugfixes from upstream
Upstream bugreports reports: http://savannah.gnu.org/bugs/index.php?30612 http://savannah.gnu.org/bugs/index.php?30723 Fixes building of dev86.
Diffstat (limited to 'main/make/APKBUILD')
-rw-r--r--main/make/APKBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
index 57cdf613d76..96ba9e78db1 100644
--- a/main/make/APKBUILD
+++ b/main/make/APKBUILD
@@ -1,16 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=make
pkgver=3.82
-pkgrel=1
+pkgrel=2
pkgdesc="GNU make utility to maintain groups of programs"
url="http://www.gnu.org/software/make"
arch="all"
license=GPL
depends=
subpackages="$pkgname-doc"
-source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ make-3.82-savannah-bugs-30612-30723.patch"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -25,4 +35,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="7f7c000e3b30c6840f2e9cf86b254fac make-3.82.tar.gz"
+md5sums="7f7c000e3b30c6840f2e9cf86b254fac make-3.82.tar.gz
+74e598a2052f7d98e3495ea9d917ecf4 make-3.82-savannah-bugs-30612-30723.patch"