aboutsummaryrefslogtreecommitdiffstats
path: root/main/make/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-04-15 07:36:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-04-15 07:36:54 +0000
commit6faedcdac2a41f9657d9824f01874878a6a9de64 (patch)
treef2e2c045a5a64af732a34c06f76d62f558516c1d /main/make/APKBUILD
parent530a7dbdf3b96548ed338c4b790902170e9362e1 (diff)
main/make: build fix: separate package() function
Diffstat (limited to 'main/make/APKBUILD')
-rw-r--r--main/make/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
index 5d2141402dc..5b0137cc885 100644
--- a/main/make/APKBUILD
+++ b/main/make/APKBUILD
@@ -1,20 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=make
pkgver=3.81
-pkgrel=1
+pkgrel=2
pkgdesc="GNU make utility to maintain groups of programs"
url="http://www.gnu.org/software/make"
license=GPL
-depends=uclibc
+depends=
subpackages="$pkgname-doc"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "$_builddir"
./configure --prefix=/usr \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --disable-nls
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}