aboutsummaryrefslogtreecommitdiffstats
path: root/main/mkfontdir
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-06 02:47:37 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:54:40 +0000
commit31c59c017274ca0eb7158a64fe90bc99b23035b9 (patch)
tree75443edc80fbc4d43757ae066e8d550b2e375f47 /main/mkfontdir
parent18e166478e2592cedc3869d63361dc3569ddc09b (diff)
main/mkfontdir: shell scripts are noarch, no test, fix deps, modernise
Diffstat (limited to 'main/mkfontdir')
-rw-r--r--main/mkfontdir/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/main/mkfontdir/APKBUILD b/main/mkfontdir/APKBUILD
index db27385f63b..2230adddfd2 100644
--- a/main/mkfontdir/APKBUILD
+++ b/main/mkfontdir/APKBUILD
@@ -1,37 +1,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkfontdir
pkgver=1.0.7
-pkgrel=0
+pkgrel=1
pkgdesc="create an index of X font files in a directory"
url="http://xorg.freedesktop.org/"
-arch="all"
+arch="noarch"
license="custom"
+options="!check" # No test suite.
subpackages="$pkgname-doc"
depends="mkfontscale"
-makedepends=
+makedepends="util-macros"
install=
triggers="$pkgname.trigger=/usr/share/fonts/*"
source="http://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="96d1920565514f90621e18a87fb5a2db9e052d1bffc6552d9659e065a21e252ab98b4e62013755032b98ed6d8c3381eb75c3c8e02651766ee4791ca622dcef1f mkfontdir-1.0.7.tar.bz2"