summaryrefslogtreecommitdiffstats
path: root/main/mousepad
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/mousepad
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/mousepad')
-rw-r--r--main/mousepad/APKBUILD28
l---------main/mousepad/mousepad.post-deinstall1
-rw-r--r--main/mousepad/mousepad.post-install4
3 files changed, 33 insertions, 0 deletions
diff --git a/main/mousepad/APKBUILD b/main/mousepad/APKBUILD
new file mode 100644
index 00000000000..ad5524f1d78
--- /dev/null
+++ b/main/mousepad/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mousepad
+pkgver=0.2.16
+pkgrel=0
+pkgdesc="Simple Text Editor for Xfce4 (based on Gedit)"
+url="http://www.xfce.org/~benny/apps.html"
+license="GPL-2"
+makedepends="pkgconfig libxfcegui4-dev intltool gettext-dev libiconv-dev
+ libsm-dev e2fsprogs-dev expat-dev"
+depends="desktop-file-utils"
+install="mousepad.post-install mousepad.post-deinstall"
+source="http://www.xfce.org/archive/xfce-4.6.0/src/$pkgname-$pkgver.tar.bz2
+ $install"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="d98854edb76d823ac20b266fdf5a64a1 mousepad-0.2.16.tar.bz2
+5ee3bbceee9d5e58b6fd8afeba87980b mousepad.post-install
+5ee3bbceee9d5e58b6fd8afeba87980b mousepad.post-deinstall"
diff --git a/main/mousepad/mousepad.post-deinstall b/main/mousepad/mousepad.post-deinstall
new file mode 120000
index 00000000000..4e963a9a02e
--- /dev/null
+++ b/main/mousepad/mousepad.post-deinstall
@@ -0,0 +1 @@
+mousepad.post-install \ No newline at end of file
diff --git a/main/mousepad/mousepad.post-install b/main/mousepad/mousepad.post-install
new file mode 100644
index 00000000000..e20da06b3d0
--- /dev/null
+++ b/main/mousepad/mousepad.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+update-desktop-database -q
+