aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-08-30 06:44:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-08-31 05:27:14 +0000
commit25cf2230b783fe49a3141ccaa075cd1014aba352 (patch)
tree22af691873fc8e8da76c8ebcb9bcdc396c63ce48 /main/musl
parent6159e1517a391e6d03e78cdf461785acc4782388 (diff)
main/musl: upgrade to 1.1.11
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch123
-rw-r--r--main/musl/0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch29
-rw-r--r--main/musl/0002-ns_parse.c-fix-ns_skiprr.patch25
-rw-r--r--main/musl/0003-handle-loss-of-syslog-socket-connection.patch77
-rw-r--r--main/musl/0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch68
-rw-r--r--main/musl/0005-mitigate-vsz-explotion.patch53
-rw-r--r--main/musl/APKBUILD38
7 files changed, 9 insertions, 404 deletions
diff --git a/main/musl/0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch b/main/musl/0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch
deleted file mode 100644
index 569182bfd62..00000000000
--- a/main/musl/0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-From f758bdca98941027145e005543c7e5bc218d98b4 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 12 Aug 2015 17:06:00 +0200
-Subject: [PATCH] fix struct tm.tm_gmtoff to be posive east of UTC
-
-Posix says that tzset() should set the "extern long timezone" (defined
-in time.h) "shall be set to the difference, in seconds, between
-Coordinated Universal Time (UTC) and local standard time." This means
-that locations east of UTC will have negative value timezone value.
-
-However the value in the glibc additional struct tm field "long
-tm_gmtoff" is positive on locations east of UTC, just like the offset in
-the zoneinfo database.
-
-From http://man7.org/linux/man-pages/man3/ctime.3.html
-
- long tm_gmtoff; /* Seconds east of UTC */
-
-This fixes coreutils' 'date -R' and 'ruby -e "puts Time.now"' to display
-correct timezone offset.
----
- src/time/__tz.c | 12 ++++++------
- src/time/localtime_r.c | 2 +-
- src/time/mktime.c | 6 +++---
- src/time/strftime.c | 4 ++--
- 4 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/src/time/__tz.c b/src/time/__tz.c
-index 102c8bc..8b84b9b 100644
---- a/src/time/__tz.c
-+++ b/src/time/__tz.c
-@@ -354,9 +354,9 @@ void __secs_to_zone(long long t, int local, int *isdst, long *offset, long *oppo
- size_t alt, i = scan_trans(t, local, &alt);
- if (i != -1) {
- *isdst = types[6*i+4];
-- *offset = -(int32_t)zi_read32(types+6*i);
-+ *offset = (int32_t)zi_read32(types+6*i);
- *zonename = (const char *)abbrevs + types[6*i+5];
-- if (oppoff) *oppoff = -(int32_t)zi_read32(types+6*alt);
-+ if (oppoff) *oppoff = (int32_t)zi_read32(types+6*alt);
- UNLOCK(lock);
- return;
- }
-@@ -390,15 +390,15 @@ void __secs_to_zone(long long t, int local, int *isdst, long *offset, long *oppo
- }
- std:
- *isdst = 0;
-- *offset = __timezone;
-- if (oppoff) *oppoff = dst_off;
-+ *offset = -__timezone;
-+ if (oppoff) *oppoff = -dst_off;
- *zonename = __tzname[0];
- UNLOCK(lock);
- return;
- dst:
- *isdst = 1;
-- *offset = dst_off;
-- if (oppoff) *oppoff = __timezone;
-+ *offset = -dst_off;
-+ if (oppoff) *oppoff = -__timezone;
- *zonename = __tzname[1];
- UNLOCK(lock);
- }
-diff --git a/src/time/localtime_r.c b/src/time/localtime_r.c
-index 1d43d9f..2e62c29 100644
---- a/src/time/localtime_r.c
-+++ b/src/time/localtime_r.c
-@@ -11,7 +11,7 @@ struct tm *__localtime_r(const time_t *restrict t, struct tm *restrict tm)
- return 0;
- }
- __secs_to_zone(*t, 0, &tm->tm_isdst, &tm->__tm_gmtoff, 0, &tm->__tm_zone);
-- if (__secs_to_tm((long long)*t - tm->__tm_gmtoff, tm) < 0) {
-+ if (__secs_to_tm((long long)*t + tm->__tm_gmtoff, tm) < 0) {
- errno = EOVERFLOW;
- return 0;
- }
-diff --git a/src/time/mktime.c b/src/time/mktime.c
-index 0ab4780..bad3f07 100644
---- a/src/time/mktime.c
-+++ b/src/time/mktime.c
-@@ -10,14 +10,14 @@ time_t mktime(struct tm *tm)
- __secs_to_zone(t, 1, &new.tm_isdst, &new.__tm_gmtoff, &opp, &new.__tm_zone);
-
- if (tm->tm_isdst>=0 && new.tm_isdst!=tm->tm_isdst)
-- t += opp - new.__tm_gmtoff;
-+ t -= opp - new.__tm_gmtoff;
-
-- t += new.__tm_gmtoff;
-+ t -= new.__tm_gmtoff;
- if ((time_t)t != t) goto error;
-
- __secs_to_zone(t, 0, &new.tm_isdst, &new.__tm_gmtoff, &opp, &new.__tm_zone);
-
-- if (__secs_to_tm(t - new.__tm_gmtoff, &new) < 0) goto error;
-+ if (__secs_to_tm(t + new.__tm_gmtoff, &new) < 0) goto error;
-
- *tm = new;
- return t;
-diff --git a/src/time/strftime.c b/src/time/strftime.c
-index 794fbe1..e945bb7 100644
---- a/src/time/strftime.c
-+++ b/src/time/strftime.c
-@@ -126,7 +126,7 @@ const char *__strftime_fmt_1(char (*s)[100], size_t *l, int f, const struct tm *
- fmt = "%H:%M";
- goto recu_strftime;
- case 's':
-- val = __tm_to_secs(tm) + tm->__tm_gmtoff;
-+ val = __tm_to_secs(tm) - tm->__tm_gmtoff;
- width = 1;
- goto number;
- case 'S':
-@@ -178,7 +178,7 @@ const char *__strftime_fmt_1(char (*s)[100], size_t *l, int f, const struct tm *
- return "";
- }
- *l = snprintf(*s, sizeof *s, "%+.2d%.2d",
-- (-tm->__tm_gmtoff)/3600,
-+ (tm->__tm_gmtoff)/3600,
- abs(tm->__tm_gmtoff%3600)/60);
- return *s;
- case 'Z':
---
-2.5.0
-
diff --git a/main/musl/0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch b/main/musl/0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch
deleted file mode 100644
index 2e4370b555b..00000000000
--- a/main/musl/0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From bf8130a2843909df0d14cce5b5149cde35f887ac Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Fri, 5 Jun 2015 10:39:42 +0300
-Subject: [PATCH] fix uselocale((locale_t)0) to not modify locale
-
-commit 68630b55c0c7 made the new locale to be assigned unconditonally
-resulting in crashes later on.
----
- src/locale/uselocale.c | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/src/locale/uselocale.c b/src/locale/uselocale.c
-index b70a0c1..0fc5ecb 100644
---- a/src/locale/uselocale.c
-+++ b/src/locale/uselocale.c
-@@ -8,9 +8,7 @@ locale_t __uselocale(locale_t new)
- locale_t old = self->locale;
- locale_t global = &libc.global_locale;
-
-- if (new == LC_GLOBAL_LOCALE) new = global;
--
-- self->locale = new;
-+ if (new) self->locale = new == LC_GLOBAL_LOCALE ? global : new;
-
- return old == global ? LC_GLOBAL_LOCALE : old;
- }
---
-2.4.2
-
diff --git a/main/musl/0002-ns_parse.c-fix-ns_skiprr.patch b/main/musl/0002-ns_parse.c-fix-ns_skiprr.patch
deleted file mode 100644
index f74d33226c1..00000000000
--- a/main/musl/0002-ns_parse.c-fix-ns_skiprr.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 06bc5ba10113ab72ac8bf0b81defffa353146496 Mon Sep 17 00:00:00 2001
-From: Yu Lu <pentium.luyu@gmail.com>
-Date: Tue, 7 Jul 2015 10:34:02 +0300
-Subject: [PATCH] ns_parse.c: fix ns_skiprr
-
----
- src/network/ns_parse.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/network/ns_parse.c b/src/network/ns_parse.c
-index 3ff33a8..d01da47 100644
---- a/src/network/ns_parse.c
-+++ b/src/network/ns_parse.c
-@@ -95,7 +95,7 @@ int ns_skiprr(const unsigned char *ptr, const unsigned char *eom, ns_sect sectio
- p += r;
- }
- }
-- return ptr - p;
-+ return p - ptr;
- bad:
- errno = EMSGSIZE;
- return -1;
---
-2.4.5
-
diff --git a/main/musl/0003-handle-loss-of-syslog-socket-connection.patch b/main/musl/0003-handle-loss-of-syslog-socket-connection.patch
deleted file mode 100644
index d33c2ff0485..00000000000
--- a/main/musl/0003-handle-loss-of-syslog-socket-connection.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 0f9c2666aca95eb98eb0ef4f4d8d1473c8ce3fa0 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Thu, 9 Jul 2015 18:36:02 +0000
-Subject: [PATCH] handle loss of syslog socket connection
-
-when traditional syslogd implementations are restarted, the old server
-socket ceases to exist and a new unix socket with the same pathname is
-created. when this happens, the default destination address associated
-with the client socket via connect is no longer valid, and attempts to
-send produce errors. this happens despite the socket being datagram
-type, and is in contrast to the behavior that would be seen with an IP
-datagram (UDP) socket.
-
-in order to avoid a situation where the application is unable to send
-further syslog messages without calling closelog, this patch makes
-syslog attempt to reconnect the socket when send returns an error
-indicating a lost connection.
-
-additionally, initial failure to connect the socket no longer results
-in the socket being closed. this ensures that an application which
-calls openlog to reserve the socket file descriptor will not run into
-a situation where transient connection failure (e.g. due to syslogd
-restart) prevents fd reservation. however, applications which may be
-unable to connect the socket later (e.g. due to chroot, restricted
-permissions, seccomp, etc.) will still fail to log if the syslog
-socket cannot be connected at openlog time or if it has to be
-reconnected later.
----
- src/misc/syslog.c | 18 +++++++++++-------
- 1 file changed, 11 insertions(+), 7 deletions(-)
-
-diff --git a/src/misc/syslog.c b/src/misc/syslog.c
-index e026f9b..9dd1ddb 100644
---- a/src/misc/syslog.c
-+++ b/src/misc/syslog.c
-@@ -48,12 +48,8 @@ void closelog(void)
-
- static void __openlog()
- {
-- int fd = socket(AF_UNIX, SOCK_DGRAM|SOCK_CLOEXEC, 0);
-- if (fd < 0) return;
-- if (connect(fd, (void *)&log_addr, sizeof log_addr) < 0)
-- close(fd);
-- else
-- log_fd = fd;
-+ log_fd = socket(AF_UNIX, SOCK_DGRAM|SOCK_CLOEXEC, 0);
-+ if (log_fd >= 0) connect(log_fd, (void *)&log_addr, sizeof log_addr);
- }
-
- void openlog(const char *ident, int opt, int facility)
-@@ -78,6 +74,11 @@ void openlog(const char *ident, int opt, int facility)
- pthread_setcancelstate(cs, 0);
- }
-
-+static int is_lost_conn(int e)
-+{
-+ return e==ECONNREFUSED || e==ECONNRESET || e==ENOTCONN || e==EPIPE;
-+}
-+
- static void _vsyslog(int priority, const char *message, va_list ap)
- {
- char timebuf[16];
-@@ -107,7 +108,10 @@ static void _vsyslog(int priority, const char *message, va_list ap)
- if (l2 >= sizeof buf - l) l = sizeof buf - 1;
- else l += l2;
- if (buf[l-1] != '\n') buf[l++] = '\n';
-- if (send(log_fd, buf, l, 0) < 0 && (log_opt & LOG_CONS)) {
-+ if (send(log_fd, buf, l, 0) < 0 && (!is_lost_conn(errno)
-+ || connect(log_fd, (void *)&log_addr, sizeof log_addr) < 0
-+ || send(log_fd, buf, l, 0) < 0)
-+ && (log_opt & LOG_CONS)) {
- fd = open("/dev/console", O_WRONLY|O_NOCTTY|O_CLOEXEC);
- if (fd >= 0) {
- dprintf(fd, "%.*s", l-hlen, buf+hlen);
---
-2.4.6
-
diff --git a/main/musl/0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch b/main/musl/0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch
deleted file mode 100644
index f3195ff39e8..00000000000
--- a/main/musl/0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 3c43c0761e1725fd5f89a9c028cbf43250abb913 Mon Sep 17 00:00:00 2001
-From: Rich Felker <dalias@aerifal.cx>
-Date: Tue, 28 Jul 2015 18:40:18 +0000
-Subject: [PATCH] fix missing synchronization in atomic store on i386 and
- x86_64
-
-despite being strongly ordered, the x86 memory model does not preclude
-reordering of loads across earlier stores. while a plain store
-suffices as a release barrier, we actually need a full barrier, since
-users of a_store subsequently load a waiter count to determine whether
-to issue a futex wait, and using a stale count will result in soft
-(fail-to-wake) deadlocks. these deadlocks were observed in malloc and
-possible with stdio locks and other libc-internal locking.
-
-on i386, an atomic operation on the caller's stack is used as the
-barrier rather than performing the store itself using xchg; this
-avoids the need to read the cache line on which the store is being
-performed. mfence is used on x86_64 where it's always available, and
-could be used on i386 with the appropriate cpu model checks if it's
-shown to perform better.
----
- arch/i386/atomic.h | 2 +-
- arch/x32/atomic.h | 2 +-
- arch/x86_64/atomic.h | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/arch/i386/atomic.h b/arch/i386/atomic.h
-index 95fecbd..25441df 100644
---- a/arch/i386/atomic.h
-+++ b/arch/i386/atomic.h
-@@ -88,7 +88,7 @@ static inline void a_dec(volatile int *x)
-
- static inline void a_store(volatile int *p, int x)
- {
-- __asm__( "movl %1, %0" : "=m"(*p) : "r"(x) : "memory" );
-+ __asm__( "movl %1, %0 ; lock ; orl $0,(%%esp)" : "=m"(*p) : "r"(x) : "memory" );
- }
-
- static inline void a_spin()
-diff --git a/arch/x32/atomic.h b/arch/x32/atomic.h
-index b2014cc..2ab1f7a 100644
---- a/arch/x32/atomic.h
-+++ b/arch/x32/atomic.h
-@@ -83,7 +83,7 @@ static inline void a_dec(volatile int *x)
-
- static inline void a_store(volatile int *p, int x)
- {
-- __asm__( "mov %1, %0" : "=m"(*p) : "r"(x) : "memory" );
-+ __asm__( "mov %1, %0 ; mfence" : "=m"(*p) : "r"(x) : "memory" );
- }
-
- static inline void a_spin()
-diff --git a/arch/x86_64/atomic.h b/arch/x86_64/atomic.h
-index b2014cc..2ab1f7a 100644
---- a/arch/x86_64/atomic.h
-+++ b/arch/x86_64/atomic.h
-@@ -83,7 +83,7 @@ static inline void a_dec(volatile int *x)
-
- static inline void a_store(volatile int *p, int x)
- {
-- __asm__( "mov %1, %0" : "=m"(*p) : "r"(x) : "memory" );
-+ __asm__( "mov %1, %0 ; mfence" : "=m"(*p) : "r"(x) : "memory" );
- }
-
- static inline void a_spin()
---
-2.4.6
-
diff --git a/main/musl/0005-mitigate-vsz-explotion.patch b/main/musl/0005-mitigate-vsz-explotion.patch
deleted file mode 100644
index 93e4a883df1..00000000000
--- a/main/musl/0005-mitigate-vsz-explotion.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/src/malloc/malloc.c b/src/malloc/malloc.c
-index eb68d55..b90636c 100644
---- a/src/malloc/malloc.c
-+++ b/src/malloc/malloc.c
-@@ -464,18 +464,6 @@ void free(void *p)
- if (next->psize != self->csize) a_crash();
-
- for (;;) {
-- /* Replace middle of large chunks with fresh zero pages */
-- if (reclaim && (self->psize & next->csize & C_INUSE)) {
-- uintptr_t a = (uintptr_t)self + SIZE_ALIGN+PAGE_SIZE-1 & -PAGE_SIZE;
-- uintptr_t b = (uintptr_t)next - SIZE_ALIGN & -PAGE_SIZE;
--#if 1
-- __madvise((void *)a, b-a, MADV_DONTNEED);
--#else
-- __mmap((void *)a, b-a, PROT_READ|PROT_WRITE,
-- MAP_PRIVATE|MAP_ANONYMOUS|MAP_FIXED, -1, 0);
--#endif
-- }
--
- if (self->psize & next->csize & C_INUSE) {
- self->csize = final_size | C_INUSE;
- next->psize = final_size | C_INUSE;
-@@ -505,6 +493,9 @@ void free(void *p)
- }
- }
-
-+ if (!(mal.binmap & 1ULL<<i))
-+ a_or_64(&mal.binmap, 1ULL<<i);
-+
- self->csize = final_size;
- next->psize = final_size;
- unlock(mal.free_lock);
-@@ -514,8 +505,17 @@ void free(void *p)
- self->next->prev = self;
- self->prev->next = self;
-
-- if (!(mal.binmap & 1ULL<<i))
-- a_or_64(&mal.binmap, 1ULL<<i);
-+ /* Replace middle of large chunks with fresh zero pages */
-+ if (reclaim) {
-+ uintptr_t a = (uintptr_t)self + SIZE_ALIGN+PAGE_SIZE-1 & -PAGE_SIZE;
-+ uintptr_t b = (uintptr_t)next - SIZE_ALIGN & -PAGE_SIZE;
-+#if 1
-+ __madvise((void *)a, b-a, MADV_DONTNEED);
-+#else
-+ __mmap((void *)a, b-a, PROT_READ|PROT_WRITE,
-+ MAP_PRIVATE|MAP_ANONYMOUS|MAP_FIXED, -1, 0);
-+#endif
-+ }
-
- unlock_bin(i);
- }
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index b49b4472904..de3321b752d 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
-pkgver=1.1.10
-pkgrel=4
+pkgver=1.1.11
+pkgrel=0
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -12,12 +12,7 @@ depends_dev="!uclibc-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-utils $pkgname-dbg libc6-compat:compat"
source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
- 0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch
- 0002-ns_parse.c-fix-ns_skiprr.patch
- 0003-handle-loss-of-syslog-socket-connection.patch
- 0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch
- 0005-mitigate-vsz-explotion.patch
- 0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch
+ arm-aeabi-mem.patch
ldconfig
__stack_chk_fail_local.c
@@ -134,37 +129,22 @@ compat() {
done
}
-md5sums="fc30892ee582c91920505bbd0021049f musl-1.1.10.tar.gz
-787a1c3661a0fcf887ec0d3c4550e90b 0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch
-b468a4063182bc08d6d100075067d7fe 0002-ns_parse.c-fix-ns_skiprr.patch
-ccf33ac806e1152b14316eadbb667fb3 0003-handle-loss-of-syslog-socket-connection.patch
-14dd2ac16696f3bd894ffd8ce2e5ea15 0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch
-4b5d01740934c549173ef89575b70f97 0005-mitigate-vsz-explotion.patch
-e60b587a8482e331d1eeb9a5534e7a03 0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch
+md5sums="48be0777e32f374d387e9cf85e36ec4d musl-1.1.11.tar.gz
+930d8a21b9a16e1f0f1ff8c2b05848cf arm-aeabi-mem.patch
830d01f7821b978df770b06db3790921 ldconfig
0df687757221bbb0fc1aa67f1bd646f9 __stack_chk_fail_local.c
57ef2c63b9ec6a2041694ace97d4ffa2 getconf.c
2b941c4251cac44988a4abfc50e21267 getent.c
45f92f8d59cf84d765de698a9578dbf4 iconv.c"
-sha256sums="45bbe9b1c7f7a0f743477af1e103b6889bfe4dd9815e16f6c89f6c90831c8b7c musl-1.1.10.tar.gz
-af5821fd50ad1587a9ef8117dc1e121cdda573f623286c6af4793e999afe840f 0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch
-8b16b8bb3eef89c799aed85caf3f495abd00bbbba1819a5feeede781040296da 0002-ns_parse.c-fix-ns_skiprr.patch
-624aeae194332de57c525306f00cc513a7708eff065fce75fe176645aa1c4062 0003-handle-loss-of-syslog-socket-connection.patch
-aca83a914e90d9d1dbf8584fd00363301d453e324477e705dc3086ba00db2fb5 0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch
-b33c02f11b8ec1aad49bc054b1a52486077156dd7d91d3b68108f7e1cb6c53ac 0005-mitigate-vsz-explotion.patch
-e46ae519bb8155e59f453c44ce65a4b001b6bb4dce601150c28b38679ab199ac 0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch
+sha256sums="bb9e6da51b7b12641f5d1abb39705c6c6c1b2fbd20002362948aa736a0aa353f musl-1.1.11.tar.gz
+b62f3bf892a4a7ea52a717a8ac39d417210599e0f603e73d122a42b87eb71af8 arm-aeabi-mem.patch
b4a2c06db38742e8c42c3c9838b285a7d8cdac6c091ff3df5ff9a15f1e41b9c7 ldconfig
299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da __stack_chk_fail_local.c
d87d0cbb3690ae2c5d8cc218349fd8278b93855dd625deaf7ae50e320aad247c getconf.c
68373a55e89ce85c562d941ccf588337d6cc6c9c17689d695f65cd7607134bbe getent.c
f79a2930a2e5bb0624321589edf8b889d1e9b603e01e6b7ae214616605b3fdd7 iconv.c"
-sha512sums="183a66a8cc9cd056a8387a1602dd44b502d8976642a21dd0dcef51165fa0dec8a4a124fda6c1918f402b20ad2d6037fcc188a8b174b07a0cbedf11fc2e011141 musl-1.1.10.tar.gz
-a77981c637a091e19435ee8b3ef3ee21dbc7171f8fa88b59cfd42934a270bb92c9c3777c176fa64c814cd531244764f440f46fce532c4192d9727baa144b98e6 0001-fix-uselocale-locale_t-0-to-not-modify-locale.patch
-08e2ce562acef8dc4232461ffdbc1c948c19025495a8c59b1328f83cb2baf3ee5db67b7d0d54794aa639d008286bedb5453d9afbc7e6e56b2f64f95d9b76be85 0002-ns_parse.c-fix-ns_skiprr.patch
-68ea86c8a388c1b122ef2e07fff847c9fbecc0ca818b2710c52976fbd91c11e0ed07c612ce8771ab6e2520e813701ea764e84744d7e08fa54616230c6499da01 0003-handle-loss-of-syslog-socket-connection.patch
-9a696b0eeebffee21ae84d4fc415b36b93e412ddd4a7272ed3cfe93e06c9815c4070ea998d63de348b2ee82180162a586326f1741f1d98088c27989354c5ecb3 0004-fix-missing-synchronization-in-atomic-store-on-i386-.patch
-2141c557a5f71a38510703d8266ed3fd21adfe137892b0fe81adcb28841b20a495f419beb273f381e6d9cb7f61cb8b182a249da61bf5a7b9df42b84235a01bc4 0005-mitigate-vsz-explotion.patch
-b2e545fef287a204e1e82243a394ffdf85e67c1b91c27c220228867a3f198d66848b4f0ff148843194008c3c5d6dd405b40933267fc13b79e55cdd74c56868a2 0001-fix-struct-tm.tm_gmtoff-to-be-posive-east-of-UTC.patch
+sha512sums="573131fe7a2c5a9c9bf796a5fc02e6ec093148648b9b43dc13d9c85e5777b1691499af6f673075a0d2b4b36c788b4dd7d72eb450c6ec3a586901bd410ee1ea6d musl-1.1.11.tar.gz
+7662df3bb3e15fa1b96370a3abbc7f17aa0246f651fa4f21c3b974ad5d6fde84d74be9a3d16976dd861839bf7785f727de5d41bb8c96ac23c38ef8b59fd82be2 arm-aeabi-mem.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c
0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d getconf.c