aboutsummaryrefslogtreecommitdiffstats
path: root/main/neon
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-03 08:03:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-03 08:17:27 -0300
commit7b6b2d93ce80b7efa768dadf66ff33454af05e6b (patch)
tree5ae85616d7e78244ac1aec6cb20b89530f00c0bf /main/neon
parentfe13982c8e0365a3ecc25ecad22cf9bebc9a720a (diff)
main/neon: remove libressl patch
Diffstat (limited to 'main/neon')
-rw-r--r--main/neon/APKBUILD15
-rw-r--r--main/neon/fix-libressl.patch31
2 files changed, 5 insertions, 41 deletions
diff --git a/main/neon/APKBUILD b/main/neon/APKBUILD
index 0caa689d512..534c75f0b9b 100644
--- a/main/neon/APKBUILD
+++ b/main/neon/APKBUILD
@@ -1,23 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=neon
pkgver=0.30.2
-pkgrel=6
+pkgrel=7
pkgdesc="HTTP and WebDAV client library with a C interface"
url="http://www.webdav.org/neon/"
arch="all"
-license="GPL LGPL"
+license="LGPL-2.0-or-later"
makedepends="expat-dev openssl-dev zlib-dev"
checkdepends="openssl"
depends="ca-certificates"
depends_dev="$makedepends"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://fossies.org/linux/www/neon-0.30.2.tar.gz
- fix-libressl.patch"
+source="https://fossies.org/linux/www/neon-0.30.2.tar.gz"
# /usr/bin/openssl invocation fails in testsuite, not sure why
options="!check"
-build () {
- cd "$builddir"
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,13 +32,10 @@ build () {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="634caf87522e0bd2695c6fba39cae2465e403f9fbd8007eb10e4e035c765d24cb8da932c67bfa35c34aa51b90c7bc7037ebebaa1ec43259366d5d07233efc631 neon-0.30.2.tar.gz
-a9ef4d5ef44518ac4df81a3e3d7532cf1eb7ee4018fd9c05ceeff0bc11d368bf2253af410e54142d73503772eb9e470ad6c0c7cd28f08d9d918b9587a685e1fc fix-libressl.patch"
+sha512sums="634caf87522e0bd2695c6fba39cae2465e403f9fbd8007eb10e4e035c765d24cb8da932c67bfa35c34aa51b90c7bc7037ebebaa1ec43259366d5d07233efc631 neon-0.30.2.tar.gz"
diff --git a/main/neon/fix-libressl.patch b/main/neon/fix-libressl.patch
deleted file mode 100644
index 226e79878eb..00000000000
--- a/main/neon/fix-libressl.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Version number juggling for libressl
-
---- a/src/ne_openssl.c 2016-09-30 10:46:00.000000000 +0200
-+++ b/src/ne_openssl.c 2016-10-06 00:19:58.366044580 +0200
-@@ -66,7 +66,7 @@
- typedef const unsigned char ne_d2i_uchar;
- #endif
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- #define X509_up_ref(x) x->references++
- #define EVP_PKEY_up_ref(x) x->references++
- #define EVP_PKEY_get0_RSA(evp) (evp->pkey.rsa)
-@@ -1199,7 +1199,7 @@
-
- int ne__ssl_init(void)
- {
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
- CRYPTO_malloc_init();
- SSL_load_error_strings();
- SSL_library_init();
-@@ -1242,7 +1242,7 @@
- "for %" NE_FMT_SIZE_T " locks.\n", num_locks);
- }
- #endif
--#endif /* OPENSSL_VERSION_NUMBER < 0x10100000L */
-+#endif /* (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) */
-
- return 0;
- }