aboutsummaryrefslogtreecommitdiffstats
path: root/main/nfdump
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-18 12:52:54 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-11-18 12:52:54 +0200
commitcfb7e5f09391c4deb56e6161f2730da3235821a8 (patch)
tree73e35b0a93fafd221f0a6fe41e632455f82e8951 /main/nfdump
parentd5da42151019d60ba291d074bb9679eb43fd88d5 (diff)
main/nfdump: fix 64-bit musl build (fts compat code)
Diffstat (limited to 'main/nfdump')
-rw-r--r--main/nfdump/APKBUILD8
-rw-r--r--main/nfdump/fix-64bit-fts-compat.patch12
2 files changed, 18 insertions, 2 deletions
diff --git a/main/nfdump/APKBUILD b/main/nfdump/APKBUILD
index ebef90cd91a..3eeb09245d6 100644
--- a/main/nfdump/APKBUILD
+++ b/main/nfdump/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nfdump
pkgver=1.6.9
-pkgrel=2
+pkgrel=3
pkgdesc="The nfdump tools collect and process netflow data on the command line."
url="http://nfdump.sourceforge.net/"
arch="all"
@@ -10,8 +10,9 @@ depends=""
depends_dev=""
makedepends="bison flex $depends_dev rrdtool-dev"
install=""
-subpackages="$pkgname-doc nfprofile"
+subpackages="$pkgname-doc $pkgname-dbg nfprofile"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-64bit-fts-compat.patch
nfcapd.confd
nfcapd.initd"
@@ -56,11 +57,14 @@ nfprofile() {
}
md5sums="6c0adfcfdacd402f2251006b4c962e3f nfdump-1.6.9.tar.gz
+e7f9467142159da5ebbb4aa858aae142 fix-64bit-fts-compat.patch
541c45b9ac0e85ac955dd58919972b18 nfcapd.confd
b084778684f622eb705980e500ec346b nfcapd.initd"
sha256sums="734943ab872d3642575add5db64ef5755f85a0a9600b120d5ee09bea4ef98dbc nfdump-1.6.9.tar.gz
+8ffd9160bb5cb639cec08ac68be5cbd33ef918e41630d02c18a75e03881cb5a9 fix-64bit-fts-compat.patch
7cb26698b26f5cd6c9c6cb2b49bb7be3cc0faffe851c5ac5c78e0a41984a276f nfcapd.confd
73e76a204ac0f1758847984d12464a8579c59ac2c2b9a3f28974f613512fcc6b nfcapd.initd"
sha512sums="07cf0bbcd001b38cc6791774d3797944256ba51513f1d97a18532248a13ad1dd0892bd75c6665aab769e1afaf99cb9e83372b79f0e814dd1e6156000eb720aa6 nfdump-1.6.9.tar.gz
+71a838d493658a3a8479bc9eca70a857fd8629937d4954d21c1d5453d6cc122c089f72e3e109425c902439ee8cfaa273b4089ac347d1fe926473ce6062b7c49a fix-64bit-fts-compat.patch
fcb467f819f2b73ac0e13de6de4d6c94cafd3866a7a56685d5d4a048fa975135299655e896ff8370c8c5061d03ab38644623f8be455c08dfe5f630f152820148 nfcapd.confd
38b25d8a2d035580d976d94e224a18de0a4d901cf200aba6fe8586d8c048c5502bfda1195c1839174826ee4bdd8c5c9f6c4bc24a0a33c953a9f7938742e30b6e nfcapd.initd"
diff --git a/main/nfdump/fix-64bit-fts-compat.patch b/main/nfdump/fix-64bit-fts-compat.patch
new file mode 100644
index 00000000000..54afdb17fda
--- /dev/null
+++ b/main/nfdump/fix-64bit-fts-compat.patch
@@ -0,0 +1,12 @@
+diff -ru nfdump-1.6.9.orig/bin/fts_compat.c nfdump-1.6.9/bin/fts_compat.c
+--- nfdump-1.6.9.orig/bin/fts_compat.c 2014-11-18 11:55:29.794283835 -0200
++++ nfdump-1.6.9/bin/fts_compat.c 2011-12-29 17:11:27.000000000 -0200
+@@ -949,7 +949,7 @@
+ #endif
+
+ #ifndef ALIGN
+-#define ALIGN(p) (((u_int)(p) + ALIGNBYTES) &~ ALIGNBYTES)
++#define ALIGN(p) (((u_long)(p) + ALIGNBYTES) &~ ALIGNBYTES)
+ #endif
+
+ size_t len;