aboutsummaryrefslogtreecommitdiffstats
path: root/main/nrpe
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/nrpe
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/nrpe')
-rw-r--r--main/nrpe/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/main/nrpe/APKBUILD b/main/nrpe/APKBUILD
index 6ceaf0b42d4..ee5db43301f 100644
--- a/main/nrpe/APKBUILD
+++ b/main/nrpe/APKBUILD
@@ -16,8 +16,15 @@ source="http://downloads.sourceforge.net/nagios/$pkgname-$pkgver.tar.gz
nrpe.initd
nrpe.confd"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
@@ -33,7 +40,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install install-daemon-config
#remove plugin since its in separate package
rm -rf "$pkgdir"/usr/lib
@@ -43,7 +50,7 @@ package() {
plugin() {
pkgdesc="Nagios plugin to check result via NRPE daemon"
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$subpkgdir" install-plugin
}