summaryrefslogtreecommitdiffstats
path: root/main/ntop
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-10-26 09:40:33 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-10-26 09:40:33 +0000
commit6d260f6fcc07a1b0ae6b34a0c07d1668fcf08556 (patch)
tree9af4cf760b25189dd9aac1119b9b02adbc98b09d /main/ntop
parenteb4656448c5960be15d07fd4e6da8fc0899a6367 (diff)
testing/ntop: moved to main
Diffstat (limited to 'main/ntop')
-rw-r--r--main/ntop/APKBUILD52
-rw-r--r--main/ntop/ntop-update-geoip-db21
-rw-r--r--main/ntop/ntop.confd9
-rw-r--r--main/ntop/ntop.initd30
-rwxr-xr-xmain/ntop/ntop.post-install3
5 files changed, 115 insertions, 0 deletions
diff --git a/main/ntop/APKBUILD b/main/ntop/APKBUILD
new file mode 100644
index 00000000000..cfcee710d10
--- /dev/null
+++ b/main/ntop/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor:
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=ntop
+pkgver=4.0
+pkgrel=1
+pkgdesc="Network traffic probe"
+url="http://www.ntop.org"
+license="GPL"
+depends=
+makedepends="autoconf automake freetype-dev gdbm-dev geoip-dev libart-lgpl-dev
+ libevent-dev libpcap-dev libpng-dev libtool libxml2-dev lua-dev
+ openssl-dev python-dev rrdtool-dev wget zlib-dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz
+ ntop.initd
+ ntop.confd
+ ntop-update-geoip-db"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-snmp
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ install -m755 -D "$srcdir"/ntop-update-geoip-db \
+ "$pkgdir"/usr/bin/ntop-update-geoip-db
+ # ntop internal db dir
+ mkdir -p $pkgdir/var/lib/ntop
+}
+
+md5sums="c5fc7863d8ba08654ef7b4d88ff860f4 ntop-4.0.tar.gz
+7fd4edf07305e0f52867256c946a5747 ntop.initd
+1303915a8435560acf27748ea0cea484 ntop.confd
+080de490aeed421775e6f2472d86cb94 ntop-update-geoip-db"
diff --git a/main/ntop/ntop-update-geoip-db b/main/ntop/ntop-update-geoip-db
new file mode 100644
index 00000000000..2bf3faaf68c
--- /dev/null
+++ b/main/ntop/ntop-update-geoip-db
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+BASE_URL=http://geolite.maxmind.com/download/geoip/database
+
+echo "Updating NTOP GeoIP databases..."
+
+cd /var/lib/ntop || exit
+
+for u in asnum/GeoIPASNum.dat.gz GeoLiteCity.dat.gz ; do
+ FILE_GZ=${u#*/}
+ FILE=${FILE_GZ%.gz}
+ wget -nv -O ${FILE_GZ} ${BASE_URL}/${u} &&
+ gunzip < ${FILE_GZ} > .${FILE} &&
+ mv -f .${FILE} ${FILE} &&
+ rm -f ${FILE_GZ} ||
+ exit
+done
+
+/etc/init.d/ntop --quiet status && /etc/init.d/ntop restart
+
+echo "NTOP GeoIP databases were successfully updated"
diff --git a/main/ntop/ntop.confd b/main/ntop/ntop.confd
new file mode 100644
index 00000000000..352a26fa9b1
--- /dev/null
+++ b/main/ntop/ntop.confd
@@ -0,0 +1,9 @@
+# Config file for /etc/init.d/ntop
+
+# Set preferred options here
+#NTOP_OPTS="--http-server 3000 --https-server 0 --interface eth0"
+
+# suggestions from bug #136983 (use it in case you experience ntop hangs)
+#NTOP_OPTS="u ntop -P /var/lib/ntop --disable-schedyield --http-server 3000 --https-server 3001"
+
+NTOP_OPTS="-u ntop -P /var/lib/ntop"
diff --git a/main/ntop/ntop.initd b/main/ntop/ntop.initd
new file mode 100644
index 00000000000..ffc2923790d
--- /dev/null
+++ b/main/ntop/ntop.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /var/lib/ntop/ntop_pw.db ]; then
+ eerror "You need to set a password first by running"
+ eerror "ntop --set-admin-password"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ntop"
+ export LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ export GDFONTPATH=/usr/share/fonts/corefonts # apparently the only font that works (#231705)
+ start-stop-daemon --start --exec /usr/bin/ntop -- -d -L ${NTOP_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ntop"
+ start-stop-daemon --stop --retry 30 --pidfile /var/run/ntop.pid
+ eend $?
+}
diff --git a/main/ntop/ntop.post-install b/main/ntop/ntop.post-install
new file mode 100755
index 00000000000..ede8a22f3c9
--- /dev/null
+++ b/main/ntop/ntop.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+adduser -h /var/lib/ntop -s /bin/false -S -H -D ntop &>/dev/null
+chown ntop /var/lib/ntop