aboutsummaryrefslogtreecommitdiffstats
path: root/main/openrc
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2021-10-21 20:47:46 -0600
committerAriadne Conill <ariadne@dereferenced.org>2021-10-21 20:47:46 -0600
commit1a30681d3faba4ea4cedeb95eb8df62d8afee434 (patch)
tree7e6cd5f38433aaaaca3fcaeefdab1aa99415d544 /main/openrc
parent41118908c73a312613577b75526d44681b73d363 (diff)
main/openrc: upgrade to 0.44.7
- remove warning about wipe_tmp for now. fixes alpine/aports#13093.
Diffstat (limited to 'main/openrc')
-rw-r--r--main/openrc/0001-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch (renamed from main/openrc/0003-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch)4
-rw-r--r--main/openrc/0001-checkpath-fix-allocation-size-of-path-buffer.patch33
-rw-r--r--main/openrc/0002-fsck-don-t-add-C0-to-busybox-fsck.patch (renamed from main/openrc/0004-fsck-don-t-add-C0-to-busybox-fsck.patch)4
-rw-r--r--main/openrc/0002-move-rc_bindir-and-rc_sbindir-definitions-to-the-top.patch40
-rw-r--r--main/openrc/0003-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch (renamed from main/openrc/0005-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch)4
-rw-r--r--main/openrc/0004-make-consolefont-service-compatible-with-busyboxs-se.patch (renamed from main/openrc/0006-make-consolefont-service-compatible-with-busyboxs-se.patch)4
-rw-r--r--main/openrc/0005-Support-early-loading-of-keymap-if-kbd-is-installed.patch (renamed from main/openrc/0007-Support-early-loading-of-keymap-if-kbd-is-installed.patch)4
-rw-r--r--main/openrc/0006-Add-support-for-starting-services-in-a-specified-VRF.patch (renamed from main/openrc/0008-Add-support-for-starting-services-in-a-specified-VRF.patch)4
-rw-r--r--main/openrc/0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch (renamed from main/openrc/0009-Clean-up-staticroute-config-remove-irrelevant-parts-.patch)4
-rw-r--r--main/openrc/0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch (renamed from main/openrc/0010-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch)4
-rw-r--r--main/openrc/0011-bootmisc-warn-about-potential-data-loss-when-wipe_tm.patch30
-rw-r--r--main/openrc/APKBUILD44
12 files changed, 35 insertions, 144 deletions
diff --git a/main/openrc/0003-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch b/main/openrc/0001-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
index 0e44b247460..3d4106009a1 100644
--- a/main/openrc/0003-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
+++ b/main/openrc/0001-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
@@ -1,4 +1,4 @@
-From 4646e98e759887baea6e87a04b2c03e1547c28dd Mon Sep 17 00:00:00 2001
+From 78245081fe109ed7777b79ba9c99890d56c21272 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 1 Feb 2017 04:04:52 +0000
Subject: [PATCH] call /sbin/mkmntdirs in localmount OpenRC service
@@ -21,5 +21,5 @@ index c571504a..14189396 100644
# The types variable must start with no, and must be a type
local critical= types="noproc" x= no_netdev= rc=
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0001-checkpath-fix-allocation-size-of-path-buffer.patch b/main/openrc/0001-checkpath-fix-allocation-size-of-path-buffer.patch
deleted file mode 100644
index b18772ab088..00000000000
--- a/main/openrc/0001-checkpath-fix-allocation-size-of-path-buffer.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From cc45b55f895d0c21b5ac3e5a65b0bf00f76adeb7 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Fri, 8 Oct 2021 04:52:55 +0100
-Subject: [PATCH] checkpath: fix allocation size of path buffer
-
-strlen's return value isn't enough to be used
-directly for (x)malloc; it doesn't include
-the null byte at the end of the string.
-
-X-Gentoo-Bug: 816900
-X-Gentoo-Bug-URL: https://bugs.gentoo.org/816900
-Fixes: #459
-Fixes: #462
----
- src/rc/checkpath.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/rc/checkpath.c b/src/rc/checkpath.c
-index bab22692..c4dd7d9d 100644
---- a/src/rc/checkpath.c
-+++ b/src/rc/checkpath.c
-@@ -151,7 +151,7 @@ static char *clean_path(char *path)
- char *ch;
- char *ch2;
- char *str;
-- str = xmalloc(strlen(path));
-+ str = xmalloc(strlen(path) + 1);
- ch = path;
- ch2 = str;
- while (true) {
---
-2.33.0
-
diff --git a/main/openrc/0004-fsck-don-t-add-C0-to-busybox-fsck.patch b/main/openrc/0002-fsck-don-t-add-C0-to-busybox-fsck.patch
index e8300efd09d..1d798185ced 100644
--- a/main/openrc/0004-fsck-don-t-add-C0-to-busybox-fsck.patch
+++ b/main/openrc/0002-fsck-don-t-add-C0-to-busybox-fsck.patch
@@ -1,4 +1,4 @@
-From 95a0e2fa4857a93aaaef6ab50742c63077d685e3 Mon Sep 17 00:00:00 2001
+From b143f35a45d59708365a52e329fd8caa6475a9bb Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Tue, 28 Nov 2017 13:35:10 +0100
Subject: [PATCH] fsck: don't add -C0 to busybox fsck
@@ -31,5 +31,5 @@ index 7052d808..99a9ae4f 100644
trap : INT QUIT
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0002-move-rc_bindir-and-rc_sbindir-definitions-to-the-top.patch b/main/openrc/0002-move-rc_bindir-and-rc_sbindir-definitions-to-the-top.patch
deleted file mode 100644
index c22f4119d77..00000000000
--- a/main/openrc/0002-move-rc_bindir-and-rc_sbindir-definitions-to-the-top.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From f46cc83ef7100ce713c4e616524e63371825e153 Mon Sep 17 00:00:00 2001
-From: William Hubbs <w.d.hubbs@gmail.com>
-Date: Tue, 21 Sep 2021 12:34:22 -0500
-Subject: [PATCH] move rc_bindir and rc_sbindir definitions to the top level
-
----
- meson.build | 2 ++
- src/rc/meson.build | 3 ---
- 2 files changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index d6836652..088cb85d 100644
---- a/meson.build
-+++ b/meson.build
-@@ -86,6 +86,8 @@ if os == 'Linux' and libexecdir == 'libexec'
- endif
- libexecdir = rootprefix / libexecdir
- rc_libexecdir = libexecdir / 'rc'
-+rc_bindir = rc_libexecdir / 'bin'
-+rc_sbindir = rc_libexecdir / 'sbin'
- sbindir = rootprefix / get_option('sbindir')
-
- selinux_dep = dependency('libselinux', required : get_option('selinux'))
-diff --git a/src/rc/meson.build b/src/rc/meson.build
-index 716963fa..ab3b0808 100644
---- a/src/rc/meson.build
-+++ b/src/rc/meson.build
-@@ -26,9 +26,6 @@ rc_wtmp_c = files([
- 'rc-wtmp.c',
- ])
-
--rc_bindir = rc_libexecdir / 'bin'
--rc_sbindir = rc_libexecdir / 'sbin'
--
- executable('rc-status',
- ['rc-status.c', rc_misc_c, usage_c, version_h],
- c_args : cc_branding_flags,
---
-2.33.0
-
diff --git a/main/openrc/0005-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch b/main/openrc/0003-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
index 34694c352c6..546ccb79687 100644
--- a/main/openrc/0005-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
+++ b/main/openrc/0003-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
@@ -1,4 +1,4 @@
-From f840faeb5f0fcbb2d7821d677f96e1e6a78bc6e2 Mon Sep 17 00:00:00 2001
+From 17f33c1968a51484eefdafbfb5b8fef5ac13d215 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 1 Feb 2017 04:17:14 +0000
Subject: [PATCH] rc: pull in sysinit and boot as stacked levels when needed
@@ -66,5 +66,5 @@ index ef46925d..82786074 100644
RC_STRING *rlevel;
TAILQ_FOREACH_REVERSE(rlevel, runlevel_chain, rc_stringlist, entries)
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0006-make-consolefont-service-compatible-with-busyboxs-se.patch b/main/openrc/0004-make-consolefont-service-compatible-with-busyboxs-se.patch
index 696c1a5ca13..b92b5ac961a 100644
--- a/main/openrc/0006-make-consolefont-service-compatible-with-busyboxs-se.patch
+++ b/main/openrc/0004-make-consolefont-service-compatible-with-busyboxs-se.patch
@@ -1,4 +1,4 @@
-From baece521bb58db0ef44aa7578ba2684c8aac18f7 Mon Sep 17 00:00:00 2001
+From 613fb7f437c42e0ed01b2366b597598235e64a2d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
Date: Wed, 17 Aug 2016 17:52:58 +0200
Subject: [PATCH] make consolefont service compatible with busyboxs setfont
@@ -66,5 +66,5 @@ index d65dd14c..ccb6ee87 100644
return $retval
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0007-Support-early-loading-of-keymap-if-kbd-is-installed.patch b/main/openrc/0005-Support-early-loading-of-keymap-if-kbd-is-installed.patch
index be753a932e6..f25d984809f 100644
--- a/main/openrc/0007-Support-early-loading-of-keymap-if-kbd-is-installed.patch
+++ b/main/openrc/0005-Support-early-loading-of-keymap-if-kbd-is-installed.patch
@@ -1,4 +1,4 @@
-From 117c2d1fae120a98fa8f5e3fa75b08044016dbef Mon Sep 17 00:00:00 2001
+From a07970bf087c089f467eefa30c2476f17f6e9536 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
Date: Thu, 7 Mar 2019 16:55:53 +0100
Subject: [PATCH] Support early loading of keymap if kbd is installed
@@ -27,5 +27,5 @@ index f304e924..7571ff3d 100644
if [ -r "$RC_LIBEXECDIR"/console/keymap ]; then
loadkeys -q "$RC_LIBEXECDIR"/console/keymap 2>/dev/null
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0008-Add-support-for-starting-services-in-a-specified-VRF.patch b/main/openrc/0006-Add-support-for-starting-services-in-a-specified-VRF.patch
index 08df91a7014..6f7ed69f037 100644
--- a/main/openrc/0008-Add-support-for-starting-services-in-a-specified-VRF.patch
+++ b/main/openrc/0006-Add-support-for-starting-services-in-a-specified-VRF.patch
@@ -1,4 +1,4 @@
-From 31b0a32737339ad1efc5b2a7efd3eca7e421d14f Mon Sep 17 00:00:00 2001
+From c250503412b061e69a99cfe12514e47fc06b5885 Mon Sep 17 00:00:00 2001
From: Ariadne Conill <ariadne@dereferenced.org>
Date: Fri, 14 Feb 2020 16:02:43 +0000
Subject: [PATCH] Add support for starting services in a specified VRF.
@@ -97,5 +97,5 @@ index e403a789..259b8166 100644
${directory:+--chdir} $directory \
${chroot:+--chroot} $chroot \
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0009-Clean-up-staticroute-config-remove-irrelevant-parts-.patch b/main/openrc/0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
index 5e493aa7eb0..34100ef6a36 100644
--- a/main/openrc/0009-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
+++ b/main/openrc/0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
@@ -1,4 +1,4 @@
-From 312ef343719e2ad33e36d9465e1fcc3cb33aa93f Mon Sep 17 00:00:00 2001
+From f406231dc9a49b67ca558983de80513f95078309 Mon Sep 17 00:00:00 2001
From: Ariadne Conill <ariadne@dereferenced.org>
Date: Wed, 8 Sep 2021 23:51:11 -0600
Subject: [PATCH] Clean up staticroute config - remove irrelevant parts (for
@@ -43,5 +43,5 @@ index 19d0961f..49d0e0bb 100644
+#staticroute="net 192.168.0.0 netmask 255.255.255.0 gw 10.73.1.1
+#net 192.168.1.0 netmask 255.255.255.0 gw 10.73.1.1"
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0010-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch b/main/openrc/0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
index f0467e83a68..f498d05f17f 100644
--- a/main/openrc/0010-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
+++ b/main/openrc/0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
@@ -1,4 +1,4 @@
-From b7a4caf79774f2a4986521dda27ddcb4d34a36c6 Mon Sep 17 00:00:00 2001
+From a756576ae62e4f24a2ea36e87053187cdfc1be63 Mon Sep 17 00:00:00 2001
From: Ariadne Conill <ariadne@dereferenced.org>
Date: Wed, 13 Oct 2021 21:12:10 -0600
Subject: [PATCH] bootmisc: switch wipe_tmp setting to no by default
@@ -40,5 +40,5 @@ index b1a849a3..8485110a 100644
cleanup_tmp_dir()
--
-2.33.0
+2.33.1
diff --git a/main/openrc/0011-bootmisc-warn-about-potential-data-loss-when-wipe_tm.patch b/main/openrc/0011-bootmisc-warn-about-potential-data-loss-when-wipe_tm.patch
deleted file mode 100644
index e1994166e21..00000000000
--- a/main/openrc/0011-bootmisc-warn-about-potential-data-loss-when-wipe_tm.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 8371334affa0e6c0f40db291280a806d20f98060 Mon Sep 17 00:00:00 2001
-From: Ariadne Conill <ariadne@dereferenced.org>
-Date: Wed, 13 Oct 2021 21:26:44 -0600
-Subject: [PATCH] bootmisc: warn about potential data loss when wipe_tmp is
- enabled
-
-See alpine/aports#13070 for more information.
----
- init.d/bootmisc.in | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/init.d/bootmisc.in b/init.d/bootmisc.in
-index 8485110a..9dd2bdef 100644
---- a/init.d/bootmisc.in
-+++ b/init.d/bootmisc.in
-@@ -31,6 +31,11 @@ cleanup_tmp_dir()
- chmod a+rwt "$dir" 2> /dev/null
- cd "$dir" || return 1
- if yesno $wipe_tmp; then
-+ ewarn "The wipe_tmp setting has been enabled in /etc/conf.d/bootmisc."
-+ ewarn "This setting is no longer recommended by Alpine due to reported"
-+ ewarn "data loss incidents relating to it."
-+ ewarn "See alpine/aports#13070 for more information."
-+
- ebegin "Wiping $dir directory"
-
- # Faster than raw find
---
-2.33.0
-
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index d5fa30633a8..d6413f6db0e 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openrc
-pkgver=0.44.6
+pkgver=0.44.7
_ver=${pkgver/_git*/}
-pkgrel=1
+pkgrel=0
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
@@ -16,17 +16,14 @@ subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev
install="$pkgname.post-install $pkgname.post-upgrade"
source="$pkgname-$pkgver.tar.gz::https://github.com/OpenRC/openrc/archive/$pkgver.tar.gz
- 0001-checkpath-fix-allocation-size-of-path-buffer.patch
- 0002-move-rc_bindir-and-rc_sbindir-definitions-to-the-top.patch
- 0003-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
- 0004-fsck-don-t-add-C0-to-busybox-fsck.patch
- 0005-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
- 0006-make-consolefont-service-compatible-with-busyboxs-se.patch
- 0007-Support-early-loading-of-keymap-if-kbd-is-installed.patch
- 0008-Add-support-for-starting-services-in-a-specified-VRF.patch
- 0009-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
- 0010-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
- 0011-bootmisc-warn-about-potential-data-loss-when-wipe_tm.patch
+ 0001-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
+ 0002-fsck-don-t-add-C0-to-busybox-fsck.patch
+ 0003-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
+ 0004-make-consolefont-service-compatible-with-busyboxs-se.patch
+ 0005-Support-early-loading-of-keymap-if-kbd-is-installed.patch
+ 0006-Add-support-for-starting-services-in-a-specified-VRF.patch
+ 0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
+ 0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
openrc.logrotate
hostname.initd
@@ -132,18 +129,15 @@ zshcomp() {
}
sha512sums="
-203e48781d5c6d1c0839439823f0f26d2fcd44cd03512379993df684693098080cf7253cffaafca76032551146c36c6fff7bc0d7c848725dc2bccf7519da6d3a openrc-0.44.6.tar.gz
-0c593760590748c57e40a0727aff4c4bf92d3a5317fe6de8a03efe44abb49a22fd76080b92d5cdb281c1c6ac51c8a1e2fbcfb78f0e7f55b94e6864832258bd04 0001-checkpath-fix-allocation-size-of-path-buffer.patch
-475fac6da12463549169b246d9f4fd546fab5f129a8a1ba9fe5ed50d1c1cf9671c28f5b7fa7907c508342edad5f5b1e952c3b084b0f38983f395cac5f7544425 0002-move-rc_bindir-and-rc_sbindir-definitions-to-the-top.patch
-b6511d880d4228134edc51070960ecd6a7c95ee34ec073a8d86ec130100c751a11c871295b2f46cd84e127de5f113051910d6ffae5a5d22831b7b6dce1a40dbe 0003-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
-f472e802853771e8fbbac31a2741455c9c4586c064835d8c9ef1700fcea0c8351d4a6d7d251e6f6e9c9ba471980edbebd9cd742f78aaf426587cfacb3aad744f 0004-fsck-don-t-add-C0-to-busybox-fsck.patch
-5e9d3a45399ee57f1ea8faaf89ae1b6f693491d1cb526ad2b956185f4ace2eb7b15b07546dbaaf5667fa2bcd01a885ce40c352450acd9de55ecfc0f4cafb0302 0005-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
-a9670c00ee6f7f9252273ef5e3c0cbce44392903c2a0a54b5006b619dfbf874d0eef94c8989ae565edf01904e4c010a5298bdb0ec040959881024aa4cf7751f6 0006-make-consolefont-service-compatible-with-busyboxs-se.patch
-3dd7fbb2a786c21e67c1d2a6485b58f84e68566aff99907a2318bfbfaf1c4c433de7e5388637a0a97dfe1cb33aee4817a8b5c8402aecc1042f34c05e85c7f91d 0007-Support-early-loading-of-keymap-if-kbd-is-installed.patch
-365cceb3e3c075209749b37dbf29bc3b1d5f4b73d06040c1e404d3f263fcecaf3903c30f0acfead54c6677b5d269703bac5f1f396fb613be58c43c248316370c 0008-Add-support-for-starting-services-in-a-specified-VRF.patch
-cd5e5eeeb98ea53818f396327f9452aabcfecf2e33c6c25cabd2f01e6d62c40d5d02a7d6349a73e5ddbeec145aab5c4fbb084a25d74cc6eeb4478c9b25db8304 0009-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
-debef6588151310822bd67f7ac74f7225a8fda0c87d8d983e86a5deac7bdb171fc808aedb711ab1446d6535eefa551405d97cbf16606b656de4bf0ad8434d929 0010-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
-4a224d50473544a1de11ff9529632c961d6b017da451e94d026ee58cda914781a3134496b29d69de9ada26adad096485530748ac772b1067831caf045e39e54c 0011-bootmisc-warn-about-potential-data-loss-when-wipe_tm.patch
+c6b3e2e30615d97a5185320a140ced881bc59ba31ea8dff5d80440396166af237826de6ffc7836ec141e305c92176cd9cc3dabff7e42ac0d80e5238513fefdb7 openrc-0.44.7.tar.gz
+6085d127f7385eb86a00676a263c8613748fb0cbbf064bc908d346a1b368e226d8a3014e871d281f57d334a70ec1301269fe431e085f0e907b4f6ef8a99bf07f 0001-call-sbin-mkmntdirs-in-localmount-OpenRC-service.patch
+3f47b4f7e6c5b7fb53ff8a13470fbada67f7470e5eba71a683e6c022162c3905f560d561c3d61698e3fde367d6ae715edf76e99949f52a22a3bbf79debc33f64 0002-fsck-don-t-add-C0-to-busybox-fsck.patch
+61c72be18283108163bde4349616e55adb535bd34312ee09f90fcd85277ffe17dcef792bbf465877c0d8b1fec87a3836f714d8d849a9cf322902a89bc1256e13 0003-rc-pull-in-sysinit-and-boot-as-stacked-levels-when-n.patch
+71a743bf969110a27259405ef4b4dc4fad608b8e49039fd6afb1b1486d0f1dfccc3ef5275410fa3d6d1554ccee59c5a3424be4f2919e14453ebb709282c588a7 0004-make-consolefont-service-compatible-with-busyboxs-se.patch
+9e2ae6c8e189ceae0f3f2662d9504f796e9a6a987a26ee2e10add85746b6596eb04cc256dc532a39f711b4e1aa07f1d12a384ef45d23cab49878b887bf0a878c 0005-Support-early-loading-of-keymap-if-kbd-is-installed.patch
+8bf00b82d7fc0eb1b529ec735009f91d277141ba7e5c04e23d10bbcf36eb453f0b31d48aec45e50b5be4c14f611acc4454933f3cefdf8beab07d851328223464 0006-Add-support-for-starting-services-in-a-specified-VRF.patch
+431ac28808e684bea5511386bf5f06efe7f509f1dbe7e15ae6309563d813deae8f3edd872a0943ef8088e3cf778d7bc5ebd15a893dc4a08f4022b7a56bbafc63 0007-Clean-up-staticroute-config-remove-irrelevant-parts-.patch
+475f4ea63b9b5d7eb9c623e96b6cc3d3072abcb7194d0045b84e0688836c8514fccfc68b0eae0b4bee60878cdea8042c3ce7e48406ee7a2f0e4a3e128a153468 0008-bootmisc-switch-wipe_tmp-setting-to-no-by-default.patch
12bb6354e808fbf47bbab963de55ee7901738b4a912659982c57ef2777fff9a670e867fcb8ec316a76b151032c92dc89a950d7d1d835ef53f753a8f3b41d2cec openrc.logrotate
493f27d588e64bb2bb542b32493ed05873f4724e8ad1751002982d7b4e07963cfb72f93603b2d678f305177cf9556d408a87b793744c6b7cd46cf9be4b744c02 hostname.initd
c06eac7264f6cc6888563feeae5ca745aae538323077903de1b19102e4f16baa34c18b8c27af5dd5423e7670834e2261e9aa55f2b1ec8d8fdc2be105fe894d55 hwdrivers.initd