aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2021-06-22 09:59:47 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2021-06-22 10:00:24 +0000
commit1e6e5ee79cc9505946a8b5d80aaa829f07237bf4 (patch)
tree42e0f1a6d9f482da6671a9c28185e4d4b5a750fd /main/openssl/APKBUILD
parente077e33c6958dcf49dc2cf7757bb43fa344986a3 (diff)
main/openssl: add support for riscv64
Diffstat (limited to 'main/openssl/APKBUILD')
-rw-r--r--main/openssl/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index fcc4b6fa5de..1cf037fff83 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openssl
pkgver=1.1.1k
_abiver=${pkgver%.*}
-pkgrel=0
+pkgrel=1
pkgdesc="Toolkit for Transport Layer Security (TLS)"
url="https://www.openssl.org/"
arch="all"
@@ -63,6 +63,7 @@ build() {
x86) _target="linux-elf" ;;
x86_64) _target="linux-x86_64"; _optflags="enable-ec_nistp_64_gcc_128" ;;
s390x) _target="linux64-s390x";;
+ riscv64) _target="linux-generic64";;
*) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
esac