aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-05 14:54:34 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 10:29:54 +0000
commit07c3d165f440d7806d133513c321460c13aee0a5 (patch)
treee29ab93d4a936d5f181d8dde9e0f1664eb97bf9c /main/openssl
parent04384a8e37cdd43ed03a9e5e79203935e3b8c673 (diff)
main/openssl: fix cross building
Diffstat (limited to 'main/openssl')
-rw-r--r--main/openssl/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 8426176d873..4a33d1b46b9 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -82,7 +82,7 @@ build() {
# Build standalone version c_rehash app, so the huge openssl
# binary is not mandatory requirement of ca-certificates
- $CC $CFLAGS -I . -I include -L . "$_builddir"/apps/c_rehash.c -o c_rehash -lcrypto || return 1
+ ${CROSS_COMPILE}$CC $CPPFLAGS $CFLAGS $LDFLAGS -I . -I include -L . "$_builddir"/apps/c_rehash.c -o c_rehash -lcrypto || return 1
}
package() {