summaryrefslogtreecommitdiffstats
path: root/main/openvpn
diff options
context:
space:
mode:
authorChristoffer Leitet <cleitet@ytre.org>2009-07-22 12:34:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 17:50:11 +0000
commit1b9e680cbcfb76b84ef02c9f552c850d0ef856c7 (patch)
tree13ea3dd1da5c63e0c1f82fed7d33b2cf5e87af89 /main/openvpn
parent900f6e704752db378c8659925a61ff08428c584c (diff)
extra/openvpn: easy-rsa fixes and init script added
* Moved easy-rsa to /etc/openvpn * Makes it easier to save certs etc. * Recommended by upstream doc: * http://openvpn.net/index.php/open-source/documentation/howto.html#pki * Fixed permissions on easy-rsa files * Fixed defunc init script * Existed in source, but not in APKBUILD * Changed configure to use iproute2 instead of ifconfig/route * De-bashified the easy-rsa scripts
Diffstat (limited to 'main/openvpn')
-rw-r--r--main/openvpn/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/main/openvpn/APKBUILD b/main/openvpn/APKBUILD
index 3b927139d10..be48bdf61dd 100644
--- a/main/openvpn/APKBUILD
+++ b/main/openvpn/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openvpn
pkgver=2.0.9
-pkgrel=0
+pkgrel=1
pkgdesc="A robust, and highly configurable VPN (Virtual Private Network)"
url="http://openvpn.sourceforge.net/"
license="custom"
subpackages="$pkgname-doc"
-depends="openssl iproute2 lzo"
+depends="iproute2"
makedepends="openssl-dev lzo-dev"
install=
source="http://$pkgname.net/release/$pkgname-$pkgver.tar.gz
openvpn-2.0.9-persistent.patch
+ openvpn.initd
"
build() {
@@ -24,7 +25,8 @@ build() {
--mandir=/usr/share/man \
--enable-ssl \
--enable-crypto \
- --disable-threads
+ --disable-threads \
+ --enable-iproute2
make || return 1
@@ -39,9 +41,10 @@ build() {
cp plugin/*/*.so "$pkgdir"/usr/lib/$pkgname
# install easy-rsa
- sed -i -e 's/--directory/-d/g; s/--mode/-m/g' easy-rsa/2.0/Makefile
+ sed -i -e 's/--directory/-d/g; s/--mode=/-m/g' easy-rsa/2.0/Makefile
+ sed -i -e '1s|#!/bin/bash|#!/bin/sh|' easy-rsa/2.0/*
make -C easy-rsa/2.0 DESTDIR="$pkgdir" \
- PREFIX=usr/share/openvpn/easy-rsa \
+ PREFIX=etc/openvpn/easy-rsa \
install
# install examples
@@ -49,6 +52,10 @@ build() {
cp -a sample-config-files "$pkgdir"/usr/share/doc/$pkgname/examples
install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ # install init.d
+ install -Dm755 ../openvpn.initd "$pkgdir"/etc/init.d/openvpn
+
}
md5sums="60745008b90b7dbe25fe8337c550fec6 openvpn-2.0.9.tar.gz
-a9075ceb8552980519132cc27fda85ac openvpn-2.0.9-persistent.patch"
+a9075ceb8552980519132cc27fda85ac openvpn-2.0.9-persistent.patch
+10390247d1fdc4fd1ebec1ebae8872be openvpn.initd"