aboutsummaryrefslogtreecommitdiffstats
path: root/main/paxmark
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-01-24 20:24:08 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-01-24 20:24:08 +0000
commitd1e475661fa736ad2725a837c516251395e0ec0f (patch)
tree9e3eb487e3ea02a9a40a596010eb5ef6f96007b9 /main/paxmark
parentbae9e2d7c0f9201348d3267596b24a34fa03dc91 (diff)
main/paxmark: remove paxctl usage
Diffstat (limited to 'main/paxmark')
-rw-r--r--main/paxmark/APKBUILD6
-rw-r--r--main/paxmark/paxmark8
2 files changed, 3 insertions, 11 deletions
diff --git a/main/paxmark/APKBUILD b/main/paxmark/APKBUILD
index c93698201c8..7dfd6f8511a 100644
--- a/main/paxmark/APKBUILD
+++ b/main/paxmark/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=paxmark
-pkgver=0.8
-pkgrel=2
+pkgver=0.9
+pkgrel=0
pkgdesc="Manage PaX marking of executables"
url="http://alpinelinux.org"
arch="noarch"
license="GPL"
-depends="paxctl attr"
+depends="attr"
makedepends=""
install=""
subpackages=""
diff --git a/main/paxmark/paxmark b/main/paxmark/paxmark
index decaa115bc6..f8486c767b6 100644
--- a/main/paxmark/paxmark
+++ b/main/paxmark/paxmark
@@ -5,14 +5,6 @@ flags="${1//[!zPpEeMmRrSs]}"
[ -n "${flags}" ] || return 0
shift
-# Create PT_PAX marking (remove after migration)
-for f in "$@"; do
- paxctl -q${flags} "${f}" >/dev/null 2>&1 && continue
- paxctl -qC${flags} "${f}" >/dev/null 2>&1 && continue
- paxctl -qc${flags} "${f}" >/dev/null 2>&1 && continue
- ret=1
-done
-
# Create XATTR_PAX marking using attr
xval=""
[ "${flags//[!P]}" ] && xval="${xval}P"