aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-file-copy-recursive/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-16 16:32:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-16 18:07:31 +0000
commit396bd8af65b9a8328c654e8a859e15e0d6d7d4a4 (patch)
treed43b79367cab5e473627adbf94f52c74871b9509 /main/perl-file-copy-recursive/APKBUILD
parent37998865cb3d5f7b88e32a374463ec25b6f52825 (diff)
main/perl-file-copy-recursive: modernize and add check
Diffstat (limited to 'main/perl-file-copy-recursive/APKBUILD')
-rw-r--r--main/perl-file-copy-recursive/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/main/perl-file-copy-recursive/APKBUILD b/main/perl-file-copy-recursive/APKBUILD
index d68d5594cc7..0277424c8ec 100644
--- a/main/perl-file-copy-recursive/APKBUILD
+++ b/main/perl-file-copy-recursive/APKBUILD
@@ -3,7 +3,7 @@
pkgname=perl-file-copy-recursive
pkgver=0.38
_realname=File-Copy-Recursive-$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Perl extension for recursively copying files and directories"
url="http://search.cpan.org/dist/File-Copy-Recursive/"
arch="noarch"
@@ -15,20 +15,23 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DM/DMUEY/$_realname.tar.gz"
-_builddir="$srcdir"/$_realname
+builddir="$srcdir/$_realname"
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="e76dc75ab456510d67c6c3a95183f72f File-Copy-Recursive-0.38.tar.gz"
-sha256sums="84ccbddf3894a88a2c2b6be68ff6ef8960037803bb36aa228b31944cfdf6deeb File-Copy-Recursive-0.38.tar.gz"
sha512sums="49e5dbfc5bdbc554ad8a019c25db85ebfa55765a73758d95271b5f3de9550fd68b4d99aa287898d86bc6c11ea8de97469a85c53d4ad8534594b411be1f18eb87 File-Copy-Recursive-0.38.tar.gz"