aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-html-quoted
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-11 11:50:31 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-13 09:08:07 +0000
commitf76022b839c77e3c54a4a871a2c8ac5facd29e04 (patch)
treea7bb632c73ee483909fd7dc29a27978d7e29d5e1 /main/perl-html-quoted
parent2860b64de14018938c6eab4bec1e09a9e2f9eee4 (diff)
main/perl-html-quoted: add missing make dependency and modernize
Diffstat (limited to 'main/perl-html-quoted')
-rw-r--r--main/perl-html-quoted/APKBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/main/perl-html-quoted/APKBUILD b/main/perl-html-quoted/APKBUILD
index 9731e1836ec..ae38e8cb842 100644
--- a/main/perl-html-quoted/APKBUILD
+++ b/main/perl-html-quoted/APKBUILD
@@ -2,37 +2,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-html-quoted
pkgver=0.03
-pkgrel=0
+pkgrel=1
pkgdesc="HTML::Quoted perl module"
url="http://search.cpan.org/dist/HTML-Quoted/"
arch="noarch"
license="GPLv2 or Artistic"
depends="perl perl-html-parser"
-makedepends="perl-dev"
-install=""
+makedepends="perl-dev perl-module-install"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RU/RUZ/HTML-Quoted-$pkgver.tar.gz"
-_builddir="$srcdir"/HTML-Quoted-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/HTML-Quoted-$pkgver"
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}