aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-locale-maketext-fuzzy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-16 15:30:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-16 15:30:26 +0000
commitca3ae5dd92d53e745a8650d92716d70163b16f3e (patch)
treed3a68e2ae738de4f8d20b521405e95354b456cc8 /main/perl-locale-maketext-fuzzy
parent0038c8df9d88f7b77a51d8b58840f4b665bc9f57 (diff)
main/perl-locale-maketext-fuzzy: fix build with newer perl
Diffstat (limited to 'main/perl-locale-maketext-fuzzy')
-rw-r--r--main/perl-locale-maketext-fuzzy/APKBUILD37
-rw-r--r--main/perl-locale-maketext-fuzzy/Locale-Maketext-Fuzzy-0.11-Fix-building-on-Perl-without-dot-in-INC.patch7
2 files changed, 24 insertions, 20 deletions
diff --git a/main/perl-locale-maketext-fuzzy/APKBUILD b/main/perl-locale-maketext-fuzzy/APKBUILD
index eb1ba6f2834..39eb649cf9e 100644
--- a/main/perl-locale-maketext-fuzzy/APKBUILD
+++ b/main/perl-locale-maketext-fuzzy/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-locale-maketext-fuzzy
pkgver=0.11
-pkgrel=0
+pkgrel=1
pkgdesc="Locale::Maketext::Fuzzy perl module"
url="http://search.cpan.org/dist/Locale-Maketext-Fuzzy/"
arch="noarch"
@@ -11,31 +11,28 @@ depends="perl"
makedepends="perl-dev"
install=""
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Locale-Maketext-Fuzzy-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Locale-Maketext-Fuzzy-$pkgver.tar.gz
+ Locale-Maketext-Fuzzy-0.11-Fix-building-on-Perl-without-dot-in-INC.patch
+ "
-_builddir="$srcdir"/Locale-Maketext-Fuzzy-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/Locale-Maketext-Fuzzy-$pkgver
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="623d791f1b57c076e18e5090d0cb2aca Locale-Maketext-Fuzzy-0.11.tar.gz"
-sha256sums="3785171ceb78cc7671319a3a6d8ced9b190e097dfcd9b2a9ebc804cd1a282f96 Locale-Maketext-Fuzzy-0.11.tar.gz"
-sha512sums="81a199c120a812604e106f083a6380dd15d61afd81ac5299d1a0d70b5f44743184234d3fc7c9c0c420a3fa0c1caf3e55d1427441cfec6df979291b67836d3c98 Locale-Maketext-Fuzzy-0.11.tar.gz"
+sha512sums="81a199c120a812604e106f083a6380dd15d61afd81ac5299d1a0d70b5f44743184234d3fc7c9c0c420a3fa0c1caf3e55d1427441cfec6df979291b67836d3c98 Locale-Maketext-Fuzzy-0.11.tar.gz
+07472faeb675790541e902c7e3b85e2524a16c41b585b029aa00a427985389a67e3b6adb8d80b1126db0c7de0a01bf99f59201d802c5ead4827dba1f3c248c35 Locale-Maketext-Fuzzy-0.11-Fix-building-on-Perl-without-dot-in-INC.patch"
diff --git a/main/perl-locale-maketext-fuzzy/Locale-Maketext-Fuzzy-0.11-Fix-building-on-Perl-without-dot-in-INC.patch b/main/perl-locale-maketext-fuzzy/Locale-Maketext-Fuzzy-0.11-Fix-building-on-Perl-without-dot-in-INC.patch
new file mode 100644
index 00000000000..3e28eda7de7
--- /dev/null
+++ b/main/perl-locale-maketext-fuzzy/Locale-Maketext-Fuzzy-0.11-Fix-building-on-Perl-without-dot-in-INC.patch
@@ -0,0 +1,7 @@
+diff -up Locale-Maketext-Fuzzy-0.11/Makefile.PL.orig Locale-Maketext-Fuzzy-0.11/Makefile.PL
+--- Locale-Maketext-Fuzzy-0.11/Makefile.PL.orig 2017-05-17 13:20:59.502830865 +0200
++++ Locale-Maketext-Fuzzy-0.11/Makefile.PL 2017-05-17 13:21:13.264776224 +0200
+@@ -1,2 +1,3 @@
+ #!/usr/bin/env perl
++BEGIN { push @INC, '.'; }
+ use inc::Module::Package 'Au:dry 1';